summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2011-01-10 11:54:52 -0700
committerChris Larson <chris_larson@mentor.com>2011-01-10 11:55:49 -0700
commitf49da3120615b2a3f10211126395b88a59a9f100 (patch)
treee561fb51bbbfd0a163c9855689dd170336fc4a7d /bin/bitbake
parent0153ace246e7c88366f45c8f035a2b4505a1c115 (diff)
downloadbitbake-f49da3120615b2a3f10211126395b88a59a9f100.tar.gz
bitbake: handle IOError from event_queue.get
These can occur in a particular ^C shutdown, so just break out of the event queue empty loop if we encounter it. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index e14c017c1..f6dcecff4 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -212,7 +212,7 @@ Default BBFILES are the .bb files in the current directory.""")
while True:
try:
event = event_queue.get(block=False)
- except Empty:
+ except (Empty, IOError):
break
if isinstance(event, logging.LogRecord):
logger.handle(event)