summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-06-18 12:50:15 +0200
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-07-06 21:55:11 +0200
commitc82926ccdd4ec4e3ad6e78a381dacb96adf9b409 (patch)
treec2218a412203d63c116db71d93c3f6c15add12f0 /bin/bitbake
parentc9e66bbae78e4804a28b3ac6cfd2de39d9c6c450 (diff)
downloadbitbake-c82926ccdd4ec4e3ad6e78a381dacb96adf9b409.tar.gz
*: use print() as a function
to make python3 happy Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake6
1 files changed, 3 insertions, 3 deletions
diff --git a/bin/bitbake b/bin/bitbake
index fdf1e20f8..7caa5d95e 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -195,13 +195,13 @@ Default BBFILES are the .bb files in the current directory.""")
uimodule = __import__("bb.ui", fromlist = [ui])
ui_init = getattr(uimodule, ui).init
except AttributeError:
- print "FATAL: Invalid user interface '%s' specified. " % ui
- print "Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'."
+ print("FATAL: Invalid user interface '%s' specified. " % ui)
+ print("Valid interfaces are 'ncurses', 'depexp' or the default, 'knotty'.")
else:
try:
return_value = ui_init(serverConnection.connection, serverConnection.events)
except Exception as e:
- print "FATAL: Unable to start to '%s' UI: %s" % (ui, e)
+ print("FATAL: Unable to start to '%s' UI: %s" % (ui, e))
raise
finally:
serverConnection.terminate()