summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-06-18 08:07:51 -0700
committerChris Larson <chris_larson@mentor.com>2010-06-21 08:05:07 -0700
commit65a51bb20677148a29b9e472f6d9d0a97798f024 (patch)
tree943f80791f24db8ba6a21adc4287d340e9d1bab8 /bin/bitbake
parent1bddc77268e57e236c274fd91c889ea00a13891b (diff)
downloadbitbake-65a51bb20677148a29b9e472f6d9d0a97798f024.tar.gz
Until the interactive mode is fixed, kill it from the valid options, to avoid confusion
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake3
1 files changed, 0 insertions, 3 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 6d4aacb92..11ca7a4e4 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -105,9 +105,6 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-f", "--force", help = "force run of specified cmd, regardless of stamp status",
action = "store_true", dest = "force", default = False)
- parser.add_option("-i", "--interactive", help = "drop into the interactive mode also called the BitBake shell.",
- action = "store_true", dest = "interactive", default = False)
-
parser.add_option("-c", "--cmd", help = "Specify task to execute. Note that this only executes the specified task for the providee and the packages it depends on, i.e. 'compile' does not implicitly call stage for the dependencies (IOW: use only if you know what you are doing). Depending on the base.bbclass a listtasks tasks is defined and will show available tasks",
action = "store", dest = "cmd")