summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-09 10:33:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-09 14:53:04 +0100
commit3c3bd0c2fa80d747f25401c17b785c7c2f3787ca (patch)
treeeb93c7eec09c6cf8c95ab65607d5c386f7842a20 /bin/bitbake
parentea0ca90dba5bbbd84d60b4462f2ca3ff5f880170 (diff)
downloadbitbake-3c3bd0c2fa80d747f25401c17b785c7c2f3787ca.tar.gz
Drop psyco support
At best it gave 1-2% improvement now, its 32 bit x86 only and isn't supported after python 2.6. PyPy is probably a better option now. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake3
1 files changed, 0 insertions, 3 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 1ed46d9b5..922a0532f 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -139,9 +139,6 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-p", "--parse-only", help = "quit after parsing the BB files (developers only)",
action = "store_true", dest = "parse_only", default = False)
- parser.add_option("-d", "--disable-psyco", help = "disable using the psyco just-in-time compiler (not recommended)",
- action = "store_true", dest = "disable_psyco", default = False)
-
parser.add_option("-s", "--show-versions", help = "show current and preferred versions of all packages",
action = "store_true", dest = "show_versions", default = False)