summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorJeff Dike <jdike@linux.intel.com>2010-06-29 13:32:04 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-01 22:32:01 +0100
commit0cd35a24d3e8d0f38b19efa66dd00096008a25af (patch)
tree5ebcbc081410c946cc15018c4637103e8b5991a2 /bin/bitbake
parentca257adc587bb0937ea76d8b32b654fdbf4192b8 (diff)
downloadbitbake-0cd35a24d3e8d0f38b19efa66dd00096008a25af.tar.gz
Move the logger initialization from cooker to utils
In order to move the environment cleaning, which wants to log a message, before cooker creation, the logging facility initialization needs to happen earlier. So, it is now in init_logger in utils.py and called from bitbake before the creation of the data object. It also seems more correct to initialize a global facility like this from a more global context than the creation of an object, of which there could theoretically be many. (From Poky rev: f9d7e9e3be89ac9141fb0eb7c71eef5a9a82add9) Signed-off-by: Jeff Dike <jdike@linux.intel.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake3
1 files changed, 3 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 326e2c917..44725edc8 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -162,6 +162,9 @@ Default BBFILES are the .bb files in the current directory.""")
# server is daemonized this logfile will be truncated.
cooker_logfile = os.path.join(os.getcwd(), "cooker.log")
+ bb.utils.init_logger(bb.msg, configuration.verbose, configuration.debug,
+ configuration.debug_domains)
+
cooker = bb.cooker.BBCooker(configuration, server)
# Clear away any spurious environment variables. But don't wipe the