summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-04-08 15:11:28 -0700
committerChris Larson <chris_larson@mentor.com>2010-04-09 12:45:59 -0700
commit69a3e4895b88110fd3a25167aa16cf7c00463175 (patch)
tree0725b1169504c601d9c7262b65c8859e61f189ab /bin/bitbake
parent3a11c2807972bbbddffde2fa67fc380d159da467 (diff)
downloadbitbake-69a3e4895b88110fd3a25167aa16cf7c00463175.tar.gz
Initialize pkgs_to_build in the BBConfiguration constructor
Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake2
1 files changed, 1 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 1a45ec4f7..a5b94bab2 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -47,6 +47,7 @@ class BBConfiguration( object ):
def __init__( self, options ):
for key, val in options.__dict__.items():
setattr( self, key, val )
+ self.pkgs_to_build = []
def print_exception(exc, value, tb):
@@ -142,7 +143,6 @@ Default BBFILES are the .bb files in the current directory.""" )
options, args = parser.parse_args(sys.argv)
configuration = BBConfiguration(options)
- configuration.pkgs_to_build = []
configuration.pkgs_to_build.extend(args[1:])
#server = bb.server.xmlrpc