summaryrefslogtreecommitdiffstats
path: root/bin/bitbake
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-31 14:49:43 +0100
committerChris Larson <chris_larson@mentor.com>2010-12-29 23:51:07 -0700
commit10c771f2f961c61628b283e9962e8aa6df73eab1 (patch)
tree728856d2da564421c34696c6606b22d2824c52cb /bin/bitbake
parentedbdf6fc89d915f06b62c5a06726e0e46a940d2e (diff)
downloadbitbake-10c771f2f961c61628b283e9962e8aa6df73eab1.tar.gz
Implement task signatures
Includes functionality to find out what changes between two different signature data dumps. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com> Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'bin/bitbake')
-rwxr-xr-xbin/bitbake3
1 files changed, 3 insertions, 0 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 63b1d1d12..e14c017c1 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -135,6 +135,9 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-n", "--dry-run", help = "don't execute, just go through the motions",
action = "store_true", dest = "dry_run", default = False)
+ parser.add_option("-S", "--dump-signatures", help = "don't execute, just dump out the signature construction information",
+ action = "store_true", dest = "dump_signatures", default = False)
+
parser.add_option("-p", "--parse-only", help = "quit after parsing the BB files (developers only)",
action = "store_true", dest = "parse_only", default = False)