aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-09-16 22:22:34 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-09-16 22:15:51 +0100
commit660e6ad4abb77c6f3c1d48bd64777dd76c05d7e2 (patch)
tree3f7715b687ffdcd4301b4a06264daba3ed326e66
parentae219e1f7460077f4492b31ac91cef4cf9b17277 (diff)
downloadbitbake-660e6ad4abb77c6f3c1d48bd64777dd76c05d7e2.tar.gz
bitbake: fix regexp deprecation warnings
See here for details: https://docs.python.org/3/library/re.html Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bblayers/query.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/bblayers/query.py b/lib/bblayers/query.py
index 6e94c8307..525d4f0d4 100644
--- a/lib/bblayers/query.py
+++ b/lib/bblayers/query.py
@@ -441,10 +441,10 @@ NOTE: .bbappend files can impact the dependencies.
line = fnfile.readline()
# The "require/include xxx" in conf/machine/*.conf, .inc and .bbclass
- conf_re = re.compile(".*/conf/machine/[^\/]*\.conf$")
- inc_re = re.compile(".*\.inc$")
+ conf_re = re.compile(r".*/conf/machine/[^\/]*\.conf$")
+ inc_re = re.compile(r".*\.inc$")
# The "inherit xxx" in .bbclass
- bbclass_re = re.compile(".*\.bbclass$")
+ bbclass_re = re.compile(r".*\.bbclass$")
for layerdir in self.bblayers:
layername = self.get_layer_name(layerdir)
for dirpath, dirnames, filenames in os.walk(layerdir):