summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2022-09-20 19:59:39 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-21 12:22:37 +0100
commiteb25cd4d64b9a4e8e2b2ce7fbccc123d00b2fc2b (patch)
tree8b0e978c7fe148ad3f3c273d96688fc0d39a2060
parentbe1ee681e8a566564549068dcf90c95c36544815 (diff)
downloadbitbake-eb25cd4d64b9a4e8e2b2ce7fbccc123d00b2fc2b.tar.gz
bitbake: Fix a few more logger debug() calls
f68682a7 ("logging: Make bitbake logger compatible with python logger") replaced several .debug() calls to make them comply with the standard python logging API, but a few were missed. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/cooker.py24
-rw-r--r--lib/bb/cookerdata.py4
2 files changed, 14 insertions, 14 deletions
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index 1b6ee3032..32a529f0f 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -425,7 +425,7 @@ class BBCooker:
sock = socket.create_connection(upstream.split(":"), 5)
sock.close()
except socket.error as e:
- bb.warn("BB_HASHSERVE_UPSTREAM is not valid, unable to connect hash equivalence server at '%s': %s"
+ bb.warn("BB_HASHSERVE_UPSTREAM is not valid, unable to connect hash equivalence server at '%s': %s"
% (upstream, repr(e)))
self.hashservaddr = "unix://%s/hashserve.sock" % self.data.getVar("TOPDIR")
@@ -1277,15 +1277,15 @@ class BBCooker:
except bb.utils.VersionStringException as vse:
bb.fatal('Error parsing LAYERRECOMMENDS_%s: %s' % (c, str(vse)))
if not res:
- parselog.debug(3,"Layer '%s' recommends version %s of layer '%s', but version %s is currently enabled in your configuration. Check that you are using the correct matching versions/branches of these two layers.", c, opstr, rec, layerver)
+ parselog.debug3("Layer '%s' recommends version %s of layer '%s', but version %s is currently enabled in your configuration. Check that you are using the correct matching versions/branches of these two layers.", c, opstr, rec, layerver)
continue
else:
- parselog.debug(3,"Layer '%s' recommends version %s of layer '%s', which exists in your configuration but does not specify a version. Check that you are using the correct matching versions/branches of these two layers.", c, opstr, rec)
+ parselog.debug3("Layer '%s' recommends version %s of layer '%s', which exists in your configuration but does not specify a version. Check that you are using the correct matching versions/branches of these two layers.", c, opstr, rec)
continue
- parselog.debug(3,"Layer '%s' recommends layer '%s', so we are adding it", c, rec)
+ parselog.debug3("Layer '%s' recommends layer '%s', so we are adding it", c, rec)
collection_depends[c].append(rec)
else:
- parselog.debug(3,"Layer '%s' recommends layer '%s', but this layer is not enabled in your configuration", c, rec)
+ parselog.debug3("Layer '%s' recommends layer '%s', but this layer is not enabled in your configuration", c, rec)
# Recursively work out collection priorities based on dependencies
def calc_layer_priority(collection):
@@ -1297,7 +1297,7 @@ class BBCooker:
if depprio > max_depprio:
max_depprio = depprio
max_depprio += 1
- parselog.debug(1, "Calculated priority of layer %s as %d", collection, max_depprio)
+ parselog.debug("Calculated priority of layer %s as %d", collection, max_depprio)
collection_priorities[collection] = max_depprio
# Calculate all layer priorities using calc_layer_priority and store in bbfile_config_priorities
@@ -1309,7 +1309,7 @@ class BBCooker:
errors = True
continue
elif regex == "":
- parselog.debug(1, "BBFILE_PATTERN_%s is empty" % c)
+ parselog.debug("BBFILE_PATTERN_%s is empty" % c)
cre = re.compile('^NULL$')
errors = False
else:
@@ -1678,7 +1678,7 @@ class BBCooker:
self.state = state.parsing
if not self.parser.parse_next():
- collectlog.debug(1, "parsing complete")
+ collectlog.debug("parsing complete")
if self.parser.error:
raise bb.BBHandledException()
self.show_appends_with_no_recipes()
@@ -1723,7 +1723,7 @@ class BBCooker:
if 'universe' in pkgs_to_build:
parselog.verbnote("The \"universe\" target is only intended for testing and may produce errors.")
- parselog.debug(1, "collating packages for \"universe\"")
+ parselog.debug("collating packages for \"universe\"")
pkgs_to_build.remove('universe')
for mc in self.multiconfigs:
for t in self.recipecaches[mc].universe_target:
@@ -1836,7 +1836,7 @@ class CookerCollectFiles(object):
"""Collect all available .bb build files"""
masked = 0
- collectlog.debug(1, "collecting .bb files")
+ collectlog.debug("collecting .bb files")
files = (config.getVar( "BBFILES") or "").split()
@@ -1923,7 +1923,7 @@ class CookerCollectFiles(object):
bbappend = []
for f in newfiles:
if bbmask and bbmask_compiled.search(f):
- collectlog.debug(1, "skipping masked file %s", f)
+ collectlog.debug("skipping masked file %s", f)
masked += 1
continue
if f.endswith('.bb'):
@@ -1931,7 +1931,7 @@ class CookerCollectFiles(object):
elif f.endswith('.bbappend'):
bbappend.append(f)
else:
- collectlog.debug(1, "skipping %s: unknown file extension", f)
+ collectlog.debug("skipping %s: unknown file extension", f)
# Build a list of .bbappend files for each .bb file
for f in bbappend:
diff --git a/lib/bb/cookerdata.py b/lib/bb/cookerdata.py
index 9706948ab..8a354fed7 100644
--- a/lib/bb/cookerdata.py
+++ b/lib/bb/cookerdata.py
@@ -356,7 +356,7 @@ class CookerDataBuilder(object):
layerconf = self._findLayerConf(data)
if layerconf:
- parselog.debug(2, "Found bblayers.conf (%s)", layerconf)
+ parselog.debug2("Found bblayers.conf (%s)", layerconf)
# By definition bblayers.conf is in conf/ of TOPDIR.
# We may have been called with cwd somewhere else so reset TOPDIR
data.setVar("TOPDIR", os.path.dirname(os.path.dirname(layerconf)))
@@ -384,7 +384,7 @@ class CookerDataBuilder(object):
raise bb.BBHandledException()
for layer in layers:
- parselog.debug(2, "Adding layer %s", layer)
+ parselog.debug2("Adding layer %s", layer)
if 'HOME' in approved and '~' in layer:
layer = os.path.expanduser(layer)
if layer.endswith('/'):