summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-18 23:22:22 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-18 23:22:22 +0000
commitb745052041a67942197f041fb8d2eeaf1a6ed799 (patch)
tree2012da6c92705c6d380fe3efd8c7be3d1f85500f
parent04e5366933599a98683f9c5adff172835403c3b9 (diff)
downloadbitbake-wmat2.tar.gz
cleanupswmat2
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--doc/user-manual/user-manual-bitbakecommand.xml156
-rw-r--r--doc/user-manual/user-manual-fetching.xml53
-rw-r--r--doc/user-manual/user-manual-intro.xml10
-rw-r--r--doc/user-manual/user-manual-metadata.xml87
4 files changed, 153 insertions, 153 deletions
diff --git a/doc/user-manual/user-manual-bitbakecommand.xml b/doc/user-manual/user-manual-bitbakecommand.xml
index 96cdf9853..78da71d06 100644
--- a/doc/user-manual/user-manual-bitbakecommand.xml
+++ b/doc/user-manual/user-manual-bitbakecommand.xml
@@ -23,75 +23,76 @@
Following is the usage and syntax for BitBake:
<literallayout class='monospaced'>
$ bitbake -h
- Usage: bitbake [options] [recipename/target ...]
-
- Executes the specified task (default is 'build') for a given set of target recipes (.bb files).
- It is assumed there is a conf/bblayers.conf available in cwd or in BBPATH which
- will provide the layer, BBFILES and other configuration information.
-
- Options:
- --version show program's version number and exit
- -h, --help show this help message and exit
- -b BUILDFILE, --buildfile=BUILDFILE
- Execute tasks from a specific .bb recipe directly.
- WARNING: Does not handle any dependencies from other
- recipes.
- -k, --continue Continue as much as possible after an error. While the
- target that failed and anything depending on it cannot
- be built, as much as possible will be built before
- stopping.
- -a, --tryaltconfigs Continue with builds by trying to use alternative
- providers where possible.
- -f, --force Force the specified targets/task to run (invalidating
- any existing stamp file).
- -c CMD, --cmd=CMD Specify the task to execute. The exact options
- available depend on the metadata. Some examples might
- be 'compile' or 'populate_sysroot' or 'listtasks' may
- give a list of the tasks available.
- -C INVALIDATE_STAMP, --clear-stamp=INVALIDATE_STAMP
- Invalidate the stamp for the specified task such as
- 'compile' and then run the default task for the
- specified target(s).
- -r PREFILE, --read=PREFILE
- Read the specified file before bitbake.conf.
- -R POSTFILE, --postread=POSTFILE
- Read the specified file after bitbake.conf.
- -v, --verbose Output more log message data to the terminal.
- -D, --debug Increase the debug level. You can specify this more
- than once.
- -n, --dry-run Don't execute, just go through the motions.
- -S, --dump-signatures
- Don't execute, just dump out the signature
- construction information.
- -p, --parse-only Quit after parsing the BB recipes.
- -s, --show-versions Show current and preferred versions of all recipes.
- -e, --environment Show the global or per-package environment complete
- with information about where variables were
- set/changed.
- -g, --graphviz Save dependency tree information for the specified
- targets in the dot syntax.
- -I EXTRA_ASSUME_PROVIDED, --ignore-deps=EXTRA_ASSUME_PROVIDED
- Assume these dependencies don't exist and are already
- provided (equivalent to ASSUME_PROVIDED). Useful to
- make dependency graphs more appealing
- -l DEBUG_DOMAINS, --log-domains=DEBUG_DOMAINS
- Show debug logging for the specified logging domains
- -P, --profile Profile the command and save reports.
- -u UI, --ui=UI The user interface to use (e.g. knotty, hob, depexp).
- -t SERVERTYPE, --servertype=SERVERTYPE
- Choose which server to use, process or xmlrpc.
- --revisions-changed Set the exit code depending on whether upstream
- floating revisions have changed or not.
- --server-only Run bitbake without a UI, only starting a server
- (cooker) process.
- B BIND, --bind=BIND The name/address for the bitbake server to bind to.
- --no-setscene Do not run any setscene tasks. sstate will be ignored
- and everything needed, built.
- --remote-server=REMOTE_SERVER
- Connect to the specified server.
- -m, --kill-server Terminate the remote server.
- --observe-only Connect to a server as an observing-only client.
- --status-only Check the status of the remote bitbake server.
+Usage: bitbake [options] [recipename/target ...]
+
+ Executes the specified task (default is 'build') for a given set of target recipes (.bb files).
+ It is assumed there is a conf/bblayers.conf available in cwd or in BBPATH which
+ will provide the layer, BBFILES and other configuration information.
+
+Options:
+ --version show program's version number and exit
+ -h, --help show this help message and exit
+ -b BUILDFILE, --buildfile=BUILDFILE
+ Execute tasks from a specific .bb recipe directly.
+ WARNING: Does not handle any dependencies from other
+ recipes.
+ -k, --continue Continue as much as possible after an error. While the
+ target that failed and anything depending on it cannot
+ be built, as much as possible will be built before
+ stopping.
+ -a, --tryaltconfigs Continue with builds by trying to use alternative
+ providers where possible.
+ -f, --force Force the specified targets/task to run (invalidating
+ any existing stamp file).
+ -c CMD, --cmd=CMD Specify the task to execute. The exact options
+ available depend on the metadata. Some examples might
+ be 'compile' or 'populate_sysroot' or 'listtasks' may
+ give a list of the tasks available.
+ -C INVALIDATE_STAMP, --clear-stamp=INVALIDATE_STAMP
+ Invalidate the stamp for the specified task such as
+ 'compile' and then run the default task for the
+ specified target(s).
+ -r PREFILE, --read=PREFILE
+ Read the specified file before bitbake.conf.
+ -R POSTFILE, --postread=POSTFILE
+ Read the specified file after bitbake.conf.
+ -v, --verbose Output more log message data to the terminal.
+ -D, --debug Increase the debug level. You can specify this more
+ than once.
+ -n, --dry-run Don't execute, just go through the motions.
+ -S, --dump-signatures
+ Don't execute, just dump out the signature
+ construction information.
+ -p, --parse-only Quit after parsing the BB recipes.
+ -s, --show-versions Show current and preferred versions of all recipes.
+ -e, --environment Show the global or per-package environment complete
+ with information about where variables were
+ set/changed.
+ -g, --graphviz Save dependency tree information for the specified
+ targets in the dot syntax.
+ -I EXTRA_ASSUME_PROVIDED, --ignore-deps=EXTRA_ASSUME_PROVIDED
+ Assume these dependencies don't exist and are already
+ provided (equivalent to ASSUME_PROVIDED). Useful to
+ make dependency graphs more appealing
+ -l DEBUG_DOMAINS, --log-domains=DEBUG_DOMAINS
+ Show debug logging for the specified logging domains
+ -P, --profile Profile the command and save reports.
+ -u UI, --ui=UI The user interface to use (e.g. knotty, hob, depexp).
+ -t SERVERTYPE, --servertype=SERVERTYPE
+ Choose which server to use, process or xmlrpc.
+ --revisions-changed Set the exit code depending on whether upstream
+ floating revisions have changed or not.
+ --server-only Run bitbake without a UI, only starting a server
+ (cooker) process.
+ -B BIND, --bind=BIND The name/address for the bitbake server to bind to.
+ --no-setscene Do not run any setscene tasks. sstate will be ignored
+ and everything needed, built.
+ --remote-server=REMOTE_SERVER
+ Connect to the specified server.
+ -m, --kill-server Terminate the remote server.
+ --observe-only Connect to a server as an observing-only client.
+ --status-only Check the status of the remote bitbake server.
+
</literallayout>
</para>
</section>
@@ -234,7 +235,7 @@
<para>
<literallayout class='monospaced'>
- BBFILES="/path/to/bbfiles/*.bb"
+ BBFILES = "/path/to/bbfiles/*.bb"
</literallayout>
With regard to dependencies, it expects the
<filename>.bb</filename> to define a
@@ -254,7 +255,8 @@
<literallayout class='monospaced'>
a.bb:
- PN = "package-a" DEPENDS += "package-b"
+ PN = "package-a"
+ DEPENDS += "package-b"
b.bb:
@@ -352,12 +354,12 @@
custom modifications that one does not want upstream.
Here is an example:
<literallayout class='monospaced'>
- BBFILES = "/stuff/openembedded/*/*.bb
- /stuff/openembedded.modified/*/*.bb" \
- BBFILE_COLLECTIONS = "upstream local" \
- BBFILE_PATTERN_upstream = "^/stuff/openembedded/" \
- BBFILE_PATTERN_local = "^/stuff/openembedded.modified/" \
- BBFILE_PRIORITY_upstream = "5" BBFILE_PRIORITY_local = "10"
+ BBFILES = "/stuff/openembedded/*/*.bb /stuff/openembedded.modified/*/*.bb"
+ BBFILE_COLLECTIONS = "upstream local"
+ BBFILE_PATTERN_upstream = "^/stuff/openembedded/"
+ BBFILE_PATTERN_local = "^/stuff/openembedded.modified/"
+ BBFILE_PRIORITY_upstream = "5"
+ BBFILE_PRIORITY_local = "10"
</literallayout>
</para>
</section>
diff --git a/doc/user-manual/user-manual-fetching.xml b/doc/user-manual/user-manual-fetching.xml
index 85df7a1a1..cdca64c80 100644
--- a/doc/user-manual/user-manual-fetching.xml
+++ b/doc/user-manual/user-manual-fetching.xml
@@ -42,19 +42,20 @@
Here are some examples that show commonly used mirror
definitions:
<literallayout class='monospaced'>
- PREMIRRORS?= "\ bzr://.*/.*
- http://somemirror.org/sources/ \n \ cvs://.*/.*
- http://somemirror.org/sources/ \n \ git://.*/.*
- http://somemirror.org/sources/ \n \ hg://.*/.*
- http://somemirror.org/sources/ \n \ osc://.*/.*
- http://somemirror.org/sources/ \n \ p4://.*/.*
- http://somemirror.org/sources/ \n \ svk://.*/.*
- http://somemirror.org/sources/ \n \ svn://.*/.*
- http://somemirror.org/sources/ \n"
- MIRRORS=+ "\ ftp://.*/.*
- http://somemirror.org/sources/ \n \ http://.*/.*
- http://somemirror.org/sources/ \n \ https://.*/.*
- http://somemirror.org/sources/ \n"
+PREMIRRORS ?= "\
+ bzr://.*/.* http://somemirror.org/sources/ \n \
+ cvs://.*/.* http://somemirror.org/sources/ \n \
+ git://.*/.* http://somemirror.org/sources/ \n \
+ hg://.*/.* http://somemirror.org/sources/ \n \
+ osc://.*/.* http://somemirror.org/sources/ \n \
+ p4://.*/.* http://somemirror.org/sources/ \n \
+ svk://.*/.* http://somemirror.org/sources/ \n \
+ svn://.*/.* http://somemirror.org/sources/ \n"
+
+MIRRORS =+ "\
+ ftp://.*/.* http://somemirror.org/sources/ \n \
+ http://.*/.* http://somemirror.org/sources/ \n \
+ https://.*/.* http://somemirror.org/sources/ \n"
</literallayout>
</para>
@@ -102,9 +103,9 @@
variations of the values in <filename>OVERRIDES</filename>.
Single files and complete directories can be specified.
<literallayout class='monospaced'>
- SRC_URI= "file://relativefile.patch"
- SRC_URI="file://relativefile.patch;this=ignored"
- SRC_URI="file:///Users/ich/very_important_software"
+ SRC_URI = "file://relativefile.patch"
+ SRC_URI = "file://relativefile.patch;this=ignored"
+ SRC_URI = "file:///Users/ich/very_important_software"
</literallayout>
</para>
</section>
@@ -142,11 +143,11 @@
method is by default pserver.
If ext is used the rsh parameter will be evaluated
and <filename>CVS_RSH</filename> will be set.
- Finally, local dir is used to checkout into a special
+ Finally, localdir is used to checkout into a special
directory relative to <filename>CVSDIR</filename>.
<literallayout class='monospaced'>
- SRC_URI="cvs://CVSROOT;module=mymodule;tag=some-version;method=ext"
- SRC_URI="cvs://CVSROOT;module=mymodule;date=20060126;localdir=usethat"
+ SRC_URI = "cvs://CVSROOT;module=mymodule;tag=some-version;method=ext"
+ SRC_URI = "cvs://CVSROOT;module=mymodule;date=20060126;localdir=usethat"
</literallayout>
</para>
</section>
@@ -163,9 +164,9 @@
“${URI}” and “${FILES}” will be replaced by the URI and
basename of the file to be fetched.
<literallayout class='monospaced'>
- SRC_URI="http://oe.handhelds.org/not_there.aac"
- SRC_URI="ftp://oe.handhelds.org/not_there_as_well.aac"
- SRC_URI="ftp://you@oe.handheld.sorg/home/you/secret.plan"
+ SRC_URI = "http://oe.handhelds.org/not_there.aac"
+ SRC_URI = "ftp://oe.handhelds.org/not_there_as_well.aac"
+ SRC_URI = "ftp://you@oe.handheld.sorg/home/you/secret.plan"
</literallayout>
</para>
</section>
@@ -195,8 +196,8 @@
If scmdata is set to “keep”, the “.svn” directories will
be available during compile-time.
<literallayout class='monospaced'>
- SRC_URI="svn://svn.oe.handhelds.org/svn;module=vip;proto=http;rev=667"
- SRC_URI="svn://svn.oe.handhelds.org/svn/;module=opie;proto=svn+ssh;date=20060126"
+ SRC_URI = "svn://svn.oe.handhelds.org/svn;module=vip;proto=http;rev=667"
+ SRC_URI = "svn://svn.oe.handhelds.org/svn/;module=opie;proto=svn+ssh;date=20060126"
</literallayout>
</para>
</section>
@@ -221,8 +222,8 @@
If scmdata is set to “keep”, the “.git” directory will be available
during compile-time.
<literallayout class='monospaced'>
- SRC_URI="git://git.oe.handhelds.org/git/vip.git;tag=version-1"
- SRC_URI="git://git.oe.handhelds.org/git/vip.git;protocol=http"
+ SRC_URI = "git://git.oe.handhelds.org/git/vip.git;tag=version-1"
+ SRC_URI = "git://git.oe.handhelds.org/git/vip.git;protocol=http"
</literallayout>
</para>
</section>
diff --git a/doc/user-manual/user-manual-intro.xml b/doc/user-manual/user-manual-intro.xml
index 5bb0bdc81..90f5a638f 100644
--- a/doc/user-manual/user-manual-intro.xml
+++ b/doc/user-manual/user-manual-intro.xml
@@ -58,18 +58,18 @@
number of projects and embedded Linux distributions
such as the Angstrom Distribution and the Yocto
Project.
- </para>
+ </para>
- <para>
+ <para>
Prior to BitBake, no other build tool adequately met the needs of
an aspiring embedded Linux distribution.
All of the build systems used by traditional desktop Linux
distributions lacked important functionality, and none of the
ad-hoc buildroot systems, prevalent in the
embedded space, were scalable or maintainable.
- </para>
+ </para>
- <para>
+ <para>
Some important original goals for BitBake were:
<itemizedlist>
<listitem><para>
@@ -144,7 +144,7 @@
Flexibility and power have always been the priorities.
It is highly extensible, supporting embedded Python code and
execution of any arbitrary tasks.
- </para>
+ </para>
</section>
<section id="Concepts">
diff --git a/doc/user-manual/user-manual-metadata.xml b/doc/user-manual/user-manual-metadata.xml
index 6eae8e05a..1be961644 100644
--- a/doc/user-manual/user-manual-metadata.xml
+++ b/doc/user-manual/user-manual-metadata.xml
@@ -38,7 +38,7 @@
<para>
<literallayout class='monospaced'>
- VARIABLE= "value"
+ VARIABLE = "value"
</literallayout>
In this example, <filename>VARIABLE</filename> is <filename>value</filename>.
</para>
@@ -55,8 +55,8 @@
<para>
<literallayout class='monospaced'>
- A= "aval"
- B= "pre${A}post"
+ A = "aval"
+ B = "pre${A}post"
</literallayout>
This results in <filename>A</filename> containing
<filename>aval</filename> and <filename>B</filename> containing
@@ -69,7 +69,7 @@
<para>
<literallayout class='monospaced'>
- A?= "aval"
+ A ?= "aval"
</literallayout>
If <filename>A</filename> is set before the above is called,
it will retain its previous value.
@@ -87,8 +87,8 @@
<para>
<literallayout class='monospaced'>
- A??= "somevalue"
- A??= "someothervalue"
+ A ??= "somevalue"
+ A ??= "someothervalue"
</literallayout>
If <filename>A</filename> is set before the above,
it will retain that value.
@@ -110,11 +110,11 @@
rather than when the variable is actually used:
<literallayout class='monospaced'>
T = "123"
- A:= "${B} ${A} test ${T}"
+ A := "${B} ${A} test ${T}"
T = "456"
- B ="${T} bval"
+ B = "${T} bval"
C = "cval"
- C:= "${C}append"
+ C := "${C}append"
</literallayout>
In this example, <filename>A</filename> would contain
<filename>test 123</filename>, <filename>B</filename> would contain
@@ -129,9 +129,9 @@
<para>
<literallayout class='monospaced'>
B = "bval"
- B+= "additionaldata"
+ B += "additionaldata"
C = "cval"
- C=+ "test"
+ C =+ "test"
</literallayout>
In this example, <filename>B</filename> is now
<filename>bval additionaldata</filename> and <filename>C</filename>
@@ -145,9 +145,9 @@
<para>
<literallayout class='monospaced'>
B = "bval"
- B.= "additionaldata"
+ B .= "additionaldata"
C = "cval"
- C=. "test"
+ C =. "test"
</literallayout>
In this example, <filename>B</filename> is now
<filename>bvaladditionaldata</filename> and
@@ -200,13 +200,10 @@
Several flags are used internally by BitBake but they can be used externally too if needed.
The standard operations mentioned above also work on flags.
<literallayout class='monospaced'>
- VARIABLE
- [
- SOMEFLAG
- ] = "value"
+ VARIABLE[SOMEFLAG] = "value"
</literallayout>
In this example, <filename>VARIABLE</filename> has a flag,
- <filename>SOMEFLAG</filename> that is set to value.
+ <filename>SOMEFLAG</filename> that is set to <filename>value</filename>.
</para>
</section>
@@ -215,8 +212,7 @@
<para>
<literallayout class='monospaced'>
- DATE =
- "${@time.strftime('%Y%m%d',time.gmtime())}"
+ DATE = "${@time.strftime('%Y%m%d',time.gmtime())}"
</literallayout>
This would result in the <filename>DATE</filename>
variable containing today's date.
@@ -409,17 +405,17 @@
unique names.
<literallayout class='monospaced'>
def get_depends(d):
- if d.getVar('SOMECONDITION', True):
- return "dependencywithcond"
- else:
- return "dependency"
+ if d.getVar('SOMECONDITION', True):
+ return "dependencywithcond"
+ else:
+ return "dependency"
SOMECONDITION = "1"
DEPENDS = "${@get_depends(d)}"
- </literallayout>
- This would result in <filename>DEPENDS</filename>
- containing <filename>dependencywithcond</filename>.
- </para>
- </note>
+ </literallayout>
+ This would result in <filename>DEPENDS</filename>
+ containing <filename>dependencywithcond</filename>.
+ </para>
+ </note>
</section>
<section id='functions'>
@@ -498,8 +494,8 @@
intertask dependencies.
<literallayout class='monospaced'>
python do_printdate () {
- import time print
- time.strftime('%Y%m%d', time.gmtime())
+ import time print
+ time.strftime('%Y%m%d', time.gmtime())
}
addtask printdate after do_fetch before do_build
</literallayout>
@@ -873,17 +869,19 @@
The intent is to make it easy to do things like email
notification on build failure.
<literallayout class='monospaced'>
- addhandler myclass_eventhandler python
- myclass_eventhandler() { from bb.event import getName from
- bb import data print("The name of the Event is %s" %
- getName(e)) print("The file we run for is %s" %
- data.getVar('FILE', e.data, True)) }
+ addhandler myclass_eventhandler
+ python myclass_eventhandler() {
+ from bb.event import getName
+ from bb import data
+ print("The name of the Event is %s" % getName(e))
+ print("The file we run for is %s" % data.getVar('FILE', e.data, True))
+ }
</literallayout>
This event handler gets called every time an event is
triggered.
A global variable "<filename>e</filename>" is defined.
"<filename>e.data</filename>" contains an instance of
- "<filename>bb.data</filename>.
+ "<filename>bb.data</filename>".
With the <filename>getName(e)</filename> method one can get
the name of the triggered event.
</para>
@@ -945,8 +943,10 @@
conditional metadata (using the <filename>OVERRIDES</filename>
mechanism) for a single version, or an optionally named range of versions:
<literallayout class='monospaced'>
- BBVERSIONS = "1.0 2.0 git" SRC_URI_git =
- "git://someurl/somepath.git"
+ BBVERSIONS = "1.0 2.0 git"
+ SRC_URI_git = "git://someurl/somepath.git"
+ </literallayout>
+ <literallayout class='monospaced'>
BBVERSIONS = "1.0.[0-6]:1.0.0+ \ 1.0.[7-9]:1.0.7+"
SRC_URI_append_1.0.7+ = "file://some_patch_which_the_new_versions_need.patch;patch=1"
</literallayout>
@@ -993,8 +993,7 @@
item listed in <filename>DEPENDS</filename> which must have
completed before that task can be executed.
<literallayout class='monospaced'>
- do_configure[deptask] =
- "do_populate_staging"
+ do_configure[deptask] = "do_populate_staging"
</literallayout>
In the previous example, the <filename>do_populate_staging</filename>
task of each item in <filename>DEPENDS</filename> must have completed before
@@ -1013,8 +1012,7 @@
item runtime dependency which must have completed before that
task can be executed.
<literallayout class='monospaced'>
- do_package_write[rdeptask] =
- "do_package"
+ do_package_write[rdeptask] = "do_package"
</literallayout>
In the previous example, the <filename>do_package</filename>
task of each item in <filename>RDEPENDS</filename> must have
@@ -1056,8 +1054,7 @@
allows an inter-dependency on specific tasks rather than specifying
the data in <filename>DEPENDS</filename>.
<literallayout class='monospaced'>
- do_patch[depends] =
- "quilt-native:do_populate_staging"
+ do_patch[depends] = "quilt-native:do_populate_staging"
</literallayout>
In the previous example, the <filename>do_populate_staging</filename>
task of the target quilt-native must have completed before the