summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBill Traynor <wmat@alphatroop.com>2013-02-26 15:44:15 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-13 22:00:26 +0000
commitd8683244401f6ac85edfbfa94ee715dee2624e00 (patch)
treedb090c7fe7c3d128ca5436d49c8c63e398d910b9
parenta86f5837fe6d9537ba61c02d6252fb21e99b0864 (diff)
downloadbitbake-d8683244401f6ac85edfbfa94ee715dee2624e00.tar.gz
user-manual-metadata.xml: Add "Inline" the the variable expansion.
Added the word Inline to the title of the Python variable expansion section. Signed-off-by: Bill Traynor <wmat@alphatroop.com>
-rw-r--r--doc/user-manual/user-manual-metadata.xml7
1 files changed, 6 insertions, 1 deletions
diff --git a/doc/user-manual/user-manual-metadata.xml b/doc/user-manual/user-manual-metadata.xml
index a7b23c06c..c72f72be2 100644
--- a/doc/user-manual/user-manual-metadata.xml
+++ b/doc/user-manual/user-manual-metadata.xml
@@ -278,7 +278,7 @@ yourself.</para>
</para>
</section>
<section>
- <title>Python variable expansion</title>
+ <title>Inline Python variable expansion</title>
<para>
<screen>
<varname>DATE</varname> =
@@ -320,6 +320,11 @@ yourself.</para>
This is only supported in .bb and .bbclass files.
</para>
<para>
+ <emphasis>NOTE:</emphasis>
+ Python functions are in the global namespace so should use
+ unique names.
+ </para>
+ <para>
<screen>def get_depends(bb, d): if
d.getVar('SOMECONDITION', True): return
"dependencywithcond" else: return "dependency"