summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 23:11:24 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-12-01 23:11:27 +0000
commitbd5a727c8447bcb747c1d2463b7de2ab6d21a7de (patch)
treef536dd40659c76050cc145eef81423f539e61ece
parentef0888f83fa4408eb768257d7e03700202faad18 (diff)
downloadbitbake-bd5a727c8447bcb747c1d2463b7de2ab6d21a7de.tar.gz
cooker.py: Allow the -e option to work with virtual classes and -b
Using bitbake -e -b virtual:xxxx:/path/to/the.bb would result in zero matches since the virtual:xxxx piece wasn't being processed. This adds in the necessary functionality to handle it correctly. [YOCTO #1793] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/cooker.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index f484b684b..cbe0d712e 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -289,7 +289,9 @@ class BBCooker:
self.status = bb.cache.CacheData(self.caches_array)
self.handleCollections( self.configuration.data.getVar("BBFILE_COLLECTIONS", 1) )
- fn = self.matchFile(buildfile)
+ fn, cls = bb.cache.Cache.virtualfn2realfn(buildfile)
+ fn = self.matchFile(fn)
+ fn = bb.cache.Cache.realfn2virtual(fn, cls)
elif len(pkgs_to_build) == 1:
self.updateCache()