summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2006-08-15 15:28:00 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2006-08-15 15:28:00 +0000
commit7915723f28e80431c5c2bbbdd45337d18baa1131 (patch)
tree379e573b40ec726ccdf5008972992aab002300c6
parent29750dce93431687d8c270fe77f00d6d12f72340 (diff)
downloadbitbake-7915723f28e80431c5c2bbbdd45337d18baa1131.tar.gz
BitBake: Bump and add Versions 1.4.5 and 1.6.1
-rw-r--r--ChangeLog22
-rwxr-xr-xbin/bitbake7
-rw-r--r--lib/bb/__init__.py2
-rw-r--r--lib/bb/methodpool.py9
4 files changed, 24 insertions, 16 deletions
diff --git a/ChangeLog b/ChangeLog
index 60faedd53..ac3566a37 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,25 @@
+Changes in Bitbake 1.6.0:
+ - Better msg handling
+ - COW dict implementation from Tim Ansell (mithro) leading
+ to better performance
+ - Speed up of -s
+
+Changes in Bitbake 1.4.4:
+ - SRCDATE now handling courtsey Justin Patrin
+ - #1017 fix to work with rm_work
+
+Changes in BitBake 1.4.2:
+ - Send logs to oe.pastebin.com instead of pastebin.com
+ fixes #856
+ - Copy the internal bitbake data before building the
+ dependency graph. This fixes nano not having a
+ virtual/libc dependency
+ - Allow multiple TARBALL_STASH entries
+ - Cache, check if the directory exists before changing
+ into it
+ - git speedup cloning by not doing a checkout
+ - allow to have spaces in filenames (.conf, .bb, .bbclass)
+
Changes in BitBake 1.4.0:
- Fix to check both RDEPENDS and RDEPENDS_${PN}
- Fix a RDEPENDS parsing bug in utils:explode_deps()
diff --git a/bin/bitbake b/bin/bitbake
index 510e45db1..b57fa8c21 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -30,7 +30,7 @@ import itertools, optparse
parsespin = itertools.cycle( r'|/-\\' )
-__version__ = "1.5.0"
+__version__ = "1.6.1"
#============================================================================#
# BBParsingStatus
@@ -1158,9 +1158,4 @@ Default BBFILES are the .bb files in the current directory.""" )
if __name__ == "__main__":
- print """WARNING, WARNING, WARNING
-This is a Bitbake from the Unstable/Development Branch.
-You might want to use the bitbake-1.4 stable branch (if you are not a BitBake developer or tester). I'm going to sleep 5 seconds now to make sure you see that."""
- import time
- time.sleep(5)
main()
diff --git a/lib/bb/__init__.py b/lib/bb/__init__.py
index 46043239f..47f46a7ac 100644
--- a/lib/bb/__init__.py
+++ b/lib/bb/__init__.py
@@ -23,7 +23,7 @@ this program; if not, write to the Free Software Foundation, Inc., 59 Temple
Place, Suite 330, Boston, MA 02111-1307 USA.
"""
-__version__ = "1.5.0"
+__version__ = "1.6.1"
__all__ = [
diff --git a/lib/bb/methodpool.py b/lib/bb/methodpool.py
index e14986bc1..ada3d2596 100644
--- a/lib/bb/methodpool.py
+++ b/lib/bb/methodpool.py
@@ -61,15 +61,6 @@ def insert_method(modulename, code, fn):
comp = better_compile(code, "<bb>", fn )
better_exec(comp, __builtins__, code, fn)
- # now some instrumentation
- code = comp.co_names
- for name in code:
- if name in ['None', 'False']:
- continue
- elif name in _parsed_fns and not _parsed_fns[name] == modulename:
- error( "Error Method already seen: %s in' %s' now in '%s'" % (name, _parsed_fns[name], modulename))
- else:
- _parsed_fns[name] = modulename
def check_insert_method(modulename, code, fn):
"""