aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2010-06-04 14:04:42 +0200
committerChris Larson <chris_larson@mentor.com>2010-06-04 16:32:51 -0700
commitfa45f5625e13a82bec70d5f10815f52fbe705166 (patch)
tree7d22dba576210a02767f629954cfe474f58d9e92
parent8a6876752b90efd81d92f0947bfc9527d8260969 (diff)
downloadbitbake-fa45f5625e13a82bec70d5f10815f52fbe705166.tar.gz
cache: do not chdir unnecessarily
previously we called chdir() twice for every target, this patch reduces the amount of chdir() calls via openembedded master from some 16000 to 4. Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com> Signed-off-by: Chris Larson <chris_larson@mentor.com>
-rw-r--r--lib/bb/cache.py16
1 files changed, 12 insertions, 4 deletions
diff --git a/lib/bb/cache.py b/lib/bb/cache.py
index 59ea8cfc7..f77a3f185 100644
--- a/lib/bb/cache.py
+++ b/lib/bb/cache.py
@@ -444,6 +444,7 @@ class Cache:
Load and parse one .bb build file
Return the data and whether parsing resulted in the file being skipped
"""
+ chdir_back = False
from bb import data, parse
@@ -451,15 +452,22 @@ class Cache:
data.setVar('TMPDIR', data.getVar('TMPDIR', config, 1) or "", config)
bbfile_loc = os.path.abspath(os.path.dirname(bbfile))
oldpath = os.path.abspath(os.getcwd())
- if parse.cached_mtime_noerror(bbfile_loc):
- os.chdir(bbfile_loc)
+ parse.cached_mtime_noerror(bbfile_loc)
bb_data = data.init_db(config)
+ # The ConfHandler first looks if there is a TOPDIR and if not
+ # then it would call getcwd().
+ # Previously, we chdir()ed to bbfile_loc, called the handler
+ # and finally chdir()ed back, a couple of thousand times. We now
+ # just fill in TOPDIR to point to bbfile_loc if there is no TOPDIR yet.
+ if not data.getVar('TOPDIR', bb_data):
+ chdir_back = True
+ data.setVar('TOPDIR', bbfile_loc, bb_data)
try:
bb_data = parse.handle(bbfile, bb_data) # read .bb data
- os.chdir(oldpath)
+ if chdir_back: os.chdir(oldpath)
return bb_data
except:
- os.chdir(oldpath)
+ if chdir_back: os.chdir(oldpath)
raise
def init(cooker):