aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2004-12-08 21:42:57 +0000
committerChris Larson <clarson@kergoth.com>2004-12-08 21:42:57 +0000
commit7f9131e7fd45924b36aaeb2a12f76b8ad2c327e3 (patch)
tree587894195d89957db4fd561e4391123b5d9665e3
parente0a6ff0140b0fd4a61d3330d3ea77b9db76824e0 (diff)
downloadbitbake-7f9131e7fd45924b36aaeb2a12f76b8ad2c327e3.tar.gz
Update the 'usage' information displayed by --help in bbimage and bbmake.
-rwxr-xr-xbin/bbimage2
-rwxr-xr-xbin/bbmake21
-rw-r--r--doc/manual/usermanual.xml28
3 files changed, 34 insertions, 17 deletions
diff --git a/bin/bbimage b/bin/bbimage
index 947d7edb0..217c9e122 100755
--- a/bin/bbimage
+++ b/bin/bbimage
@@ -41,7 +41,7 @@ def usage():
sys.exit(0)
def version():
- print "BitBake Build Infrastructure Core version %s" % bb.__version__
+ print "BitBake Build Tool Core version %s" % bb.__version__
print "BBImage version %s" % __version__
def emit_bb(d, base_d = {}):
diff --git a/bin/bbmake b/bin/bbmake
index 9ff8b1ec2..23a079a9f 100755
--- a/bin/bbmake
+++ b/bin/bbmake
@@ -46,12 +46,13 @@ bbfile_priority = {}
bbdebug = 0
def handle_options( args ):
- parser = optparse.OptionParser( version = "BitBake Build Infrastructure Core version %s, %%prog version %s" % ( bb.__version__, __version__ ),
+ parser = optparse.OptionParser( version = "BitBake Build Tool Core version %s, %%prog version %s" % ( bb.__version__, __version__ ),
usage = """%prog [options] [package ...]
-Builds specified packages, expecting that the .bb files
-it has to work from are in BBFILES
-Default packages are all packages in BBFILES.
+Executes the specified task (default is 'build') for a given set of BitBake files.
+It expects that BBFILES is defined, which is a space seperated list of files to
+be executed. BBFILES does support wildcards.
+Default packages to be executed are all packages in BBFILES.
Default BBFILES are the .bb files in the current directory.""" )
parser.add_option( "-k", "--continue", help = "continue as much as possible after an error. While the target that failed, and those that depend on it, cannot be remade, the other dependencies of these targets can be processed all the same.",
@@ -61,15 +62,7 @@ Default BBFILES are the .bb files in the current directory.""" )
action = "store_true", dest = "force", default = False )
- parser.add_option( "-c", "--cmd", help = "specify command to pass to bbbuild. Valid commands are "
- "'fetch' (fetch all sources), "
- "'unpack' (unpack the sources), "
- "'patch' (apply the patches), "
- "'configure' (configure the source tree), "
- "'compile' (compile the source tree), "
- "'stage' (install libraries and headers needed for subsequent packages), "
- "'install' (install libraries and executables), and"
- "'package' (package files into the selected package format)",
+ parser.add_option( "-c", "--cmd", help = "Specify task to execute",
action = "store", dest = "cmd", default = "build" )
parser.add_option( "-r", "--read", help = "read the specified file before bitbake.conf",
@@ -78,7 +71,7 @@ Default BBFILES are the .bb files in the current directory.""" )
parser.add_option( "-v", "--verbose", help = "output more chit-chat to the terminal",
action = "store_true", dest = "verbose", default = False )
- parser.add_option( "-n", "--dry-run", help = "don't call bbbuild, just go through the motions",
+ parser.add_option( "-n", "--dry-run", help = "don't execute, just go through the motions",
action = "store_true", dest = "dry_run", default = False )
parser.add_option( "-p", "--parse-only", help = "quit after parsing the BB files (developers only)",
diff --git a/doc/manual/usermanual.xml b/doc/manual/usermanual.xml
index d47d5ded6..799c0df4e 100644
--- a/doc/manual/usermanual.xml
+++ b/doc/manual/usermanual.xml
@@ -205,11 +205,35 @@ addtask printdate before do_build</screen></para>
<title>Commands</title>
<section>
<title>bbread</title>
- <para>test</para>
+ <para>bbread is a command for displaying BitBake metadata. When run with no arguments, it has the core parse 'conf/bitbake.conf', as located in BBPATH, and displays that. If you supply a file on the commandline, such as a .bb, then it parses that afterwards, using the aforementioned configuration metadata.</para>
</section>
<section>
<title>bbmake</title>
- <para>test</para>
+ <programlisting format="linespecific"><literal>usage: bbmake [options] [package ...]
+
+Executes the specified task (default is 'build') for a given set of BitBake files.
+It expects that BBFILES is defined, which is a space seperated list of files to
+be executed. BBFILES does support wildcards.
+Default packages to be executed are all packages in BBFILES.
+Default BBFILES are the .bb files in the current directory.
+
+options:
+ --version show program's version number and exit
+ -h, --help show this help message and exit
+ -k, --continue continue as much as possible after an error. While the
+ target that failed, and those that depend on it, cannot
+ be remade, the other dependencies of these targets can
+ be processed all the same.
+ -f, --force force run of specified cmd, regardless of stamp status
+ -cCMD, --cmd=CMD Specify task to execute
+ -rFILE, --read=FILE read the specified file before bitbake.conf
+ -v, --verbose output more chit-chat to the terminal
+ -n, --dry-run don't execute, just go through the motions
+ -p, --parse-only quit after parsing the BB files (developers only)
+ -d, --disable-psyco disable using the psyco just-in-time compiler (not
+ recommended)
+ -s, --show-versions show current and preferred versions of all packages</literal>
+ </programlisting>
</section>
</chapter>
<appendix>