aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJason Wessel <jason.wessel@windriver.com>2012-09-17 17:43:17 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-24 15:26:09 +0100
commit440e479f3e248482c38c149643403c6907ac7034 (patch)
tree8a68a0a804e511a46cd50a38768a56e50bff1c67
parent1270a07713e2a6c6e6fadcc61b785aebc99ae17b (diff)
downloadbitbake-440e479f3e248482c38c149643403c6907ac7034.tar.gz
runqueue: Add --no-setscene to skip all setscene tasks
Mainly intended for the purpose of debugging or forcing builds from source, the --no-setscene will prevent any setscene tasks from running. Signed-off-by: Jason Wessel <jason.wessel@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rwxr-xr-xbin/bitbake2
-rw-r--r--lib/bb/runqueue.py13
2 files changed, 9 insertions, 6 deletions
diff --git a/bin/bitbake b/bin/bitbake
index ed2ff0630..8c4602425 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -174,6 +174,8 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-B", "--bind", help = "The name/address for the bitbake server to bind to",
action = "store", dest = "bind", default = False)
+ parser.add_option("", "--no-setscene", help = "Do not run any setscene tasks, forces builds",
+ action = "store_true", dest = "nosetscene", default = False)
options, args = parser.parse_args(sys.argv)
configuration = BBConfiguration(options)
diff --git a/lib/bb/runqueue.py b/lib/bb/runqueue.py
index b90b7e7e4..75797e252 100644
--- a/lib/bb/runqueue.py
+++ b/lib/bb/runqueue.py
@@ -692,13 +692,14 @@ class RunQueueData:
stampfnwhitelist.append(fn)
self.stampfnwhitelist = stampfnwhitelist
- # Interate over the task list looking for tasks with a 'setscene' function
+ # Iterate over the task list looking for tasks with a 'setscene' function
self.runq_setscene = []
- for task in range(len(self.runq_fnid)):
- setscene = taskData.gettask_id(self.taskData.fn_index[self.runq_fnid[task]], self.runq_task[task] + "_setscene", False)
- if not setscene:
- continue
- self.runq_setscene.append(task)
+ if not self.cooker.configuration.nosetscene:
+ for task in range(len(self.runq_fnid)):
+ setscene = taskData.gettask_id(self.taskData.fn_index[self.runq_fnid[task]], self.runq_task[task] + "_setscene", False)
+ if not setscene:
+ continue
+ self.runq_setscene.append(task)
def invalidate_task(fn, taskname, error_nostamp):
taskdep = self.dataCache.task_deps[fn]