aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2005-05-26 13:25:30 +0000
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2005-05-26 13:25:30 +0000
commit4407d25b8fc3b8285cc78137a3dda1322f3c9189 (patch)
tree5196709d9d475e9d10338b27b5bd2db85c467780
parentb640c969e03c27d8b9da0094c9fddd811ef29f94 (diff)
downloadbitbake-4407d25b8fc3b8285cc78137a3dda1322f3c9189.tar.gz
- remove checking for return if parse-only is set when executing just one BB
- don't sys.exit() for parse-only, but return. This makes dropping into the Python interactive mode possible.
-rwxr-xr-xbin/bitbake8
1 files changed, 2 insertions, 6 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 1fc6fd073..970cac281 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -557,10 +557,6 @@ class BBCooker:
except IOError:
bb.fatal("Unable to open %s" % fn)
- if make.options.parse_only:
- print "Requested parsing .bb files only. Exiting."
- sys.exit(0)
-
name = bb.data.getVar('PN', d, 1)
bb.event.fire(bb.event.PkgStarted(name, d))
try:
@@ -638,7 +634,7 @@ class BBCooker:
self.parseConfigurationFile( f )
self.parseConfigurationFile( os.path.join( "conf", "bitbake.conf" ) )
-
+
bb.data.update_data( make.cfg )
if not bb.data.getVar("BUILDNAME", make.cfg):
@@ -696,7 +692,7 @@ class BBCooker:
print
if make.options.parse_only:
print "Requested parsing .bb files only. Exiting."
- sys.exit(0)
+ return
self.buildDepgraph()