aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEren Türkay <eren@hambedded.org>2012-12-12 22:35:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-14 13:04:38 +0000
commit0668a0ea968baf930f05806a5452c8dbe4ec35ce (patch)
tree206a07df6885739b49e8e2aa6192e6ac11c201cd
parent7467d7d66b24cc8f43ab168e65895e7c4aee6092 (diff)
downloadbitbake-0668a0ea968baf930f05806a5452c8dbe4ec35ce.tar.gz
bitbake.vim: detect *.bbappend files in ftdetect automatically
Currently, *.bb and *.bbclass files are automatically highlighted and detected as a bitbake file. Since *.bbappend files are also bitbake files, vim plugin should automatically detect and highlight it as well. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--contrib/vim/ftdetect/bitbake.vim4
1 files changed, 2 insertions, 2 deletions
diff --git a/contrib/vim/ftdetect/bitbake.vim b/contrib/vim/ftdetect/bitbake.vim
index 179e4d988..b9529e669 100644
--- a/contrib/vim/ftdetect/bitbake.vim
+++ b/contrib/vim/ftdetect/bitbake.vim
@@ -10,8 +10,8 @@ if &compatible || version < 600
finish
endif
-" .bb and .bbclass
-au BufNewFile,BufRead *.b{b,bclass} set filetype=bitbake
+" .bb, .bbappend and .bbclass
+au BufNewFile,BufRead *.{bb,bbappend,bbclass} set filetype=bitbake
" .inc
au BufNewFile,BufRead *.inc set filetype=bitbake