diff options
author | Chris Larson <clarson@kergoth.com> | 2004-12-08 22:48:08 +0000 |
---|---|---|
committer | Chris Larson <clarson@kergoth.com> | 2004-12-08 22:48:08 +0000 |
commit | 0192abf5d06a3c2e0290a838cadadf303363336c (patch) | |
tree | 398369edd875377935634e9598a9763dd4697382 | |
parent | 694a396abf10001d2b605bbb83e55ab44805a17f (diff) | |
download | bitbake-0192abf5d06a3c2e0290a838cadadf303363336c.tar.gz |
Make bbread spit out a nicer error when it encounters an IOError.
-rw-r--r-- | MANIFEST | 2 | ||||
-rwxr-xr-x | bin/bbread | 7 | ||||
-rwxr-xr-x | setup.py | 2 |
3 files changed, 8 insertions, 3 deletions
@@ -1,7 +1,7 @@ MANIFEST setup.py bin/bbimage -bin/bbmake +bin/bitbake bin/bbread lib/bb/__init__.py lib/bb/build.py @@ -22,11 +22,16 @@ sys.path.append(os.path.join(os.path.dirname(os.path.dirname(sys.argv[0])), 'lib import bb, bb.parse, bb.build d = bb.data.init() -d = bb.parse.handle(os.path.join('conf', 'bitbake.conf'), d) +try: + d = bb.parse.handle(os.path.join('conf', 'bitbake.conf'), d) +except IOError, e: + bb.fatal("Unable to read conf/bitbake.conf: %s" % e) if len(sys.argv) == 2: try: d = bb.parse.handle(sys.argv[1], d) + except IOError, e: + bb.fatal("Unable to read %s: %s" % (sys.argv[1], e)) except Exception, e: bb.fatal("%s" % e) @@ -54,7 +54,7 @@ setup(name='bitbake', author_email='clarson@elinux.org', packages=['bb', 'bb.parse'], package_dir={'bb': os.path.join('lib', 'bb')}, - scripts=[os.path.join('bin', 'bbmake'), + scripts=[os.path.join('bin', 'bitbake'), os.path.join('bin', 'bbread'), os.path.join('bin', 'bbimage')], data_files=[(os.path.join(bbdir, 'conf'), [os.path.join('conf', 'bitbake.conf')]), |