aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Francois Dagenais <jeff.dagenais@gmail.com>2020-08-20 17:50:00 -0400
committerSteve Sakoman <steve@sakoman.com>2020-08-24 05:25:26 -1000
commitbefc11acd25a9d9a2d44c20a0e33ada740407af7 (patch)
treea7dfd75b3750be8878528e1c90e550f514886a0c
parent838a89141fd6a75da9f982ad2b035e823b692d2a (diff)
downloadbitbake-befc11acd25a9d9a2d44c20a0e33ada740407af7.tar.gz
siggen: clean_basepath: remove recipe full path when virtual:xyz present
Before this fix, this example basepath (a): virtual:native:/full/path/to/recipes-example/helloworld/helloworld_1.2.3.bb:do_compile would get incorrectly "cleaned" into: helloworld/helloworld_1.2.3.bb:do_compile:virtual:native:/full/path/to/recipes-example/helloworld/helloworld_1.2.3.bb When searching backwards in `a` trying to isolate the 'virtual:xyz' to add it to the end of the string, we need to consider `a` still has the recipe path and taskname. So stoping the rsplit after only 1 split is not enough. We want to reach the second ':' from the end. This way, we obtain: helloworld/helloworld_1.2.3.bb:do_compile:virtual:native reviewed-by: Maxime Roussin-BĂ©langer <maxime.roussinbelanger@gmail.com> Signed-off-by: Jean-Francois Dagenais <jeff.dagenais@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit d193d93422a0ad62aa35b5d4ca5da8d422f72180) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--lib/bb/siggen.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/bb/siggen.py b/lib/bb/siggen.py
index 94d1762df..26fa7f05c 100644
--- a/lib/bb/siggen.py
+++ b/lib/bb/siggen.py
@@ -706,7 +706,7 @@ def clean_basepath(a):
_, mc, a = a.split(":", 2)
b = a.rsplit("/", 2)[1] + '/' + a.rsplit("/", 2)[2]
if a.startswith("virtual:"):
- b = b + ":" + a.rsplit(":", 1)[0]
+ b = b + ":" + a.rsplit(":", 2)[0]
if mc:
b = b + ":mc:" + mc
return b