summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2006-05-04 20:53:42 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2006-05-04 20:53:42 +0000
commit3bf31c7241195f015714ce2ca04bef78676e09e5 (patch)
tree05ff66b51c48a12930fe5b0cc162c2ca488199f2
parent59e0967374514186737917e680091e57c0ad20ff (diff)
downloadbitbake-3bf31c7241195f015714ce2ca04bef78676e09e5.tar.gz
bitbake-1.4/lib/bb/__init__.py:
bitbake-1.4/bin/bitbake: Increase the version to 1.4.2 bitbake-1.4/ChangeLog: Update the ChangeLog to mention the included backports.
-rw-r--r--ChangeLog12
-rwxr-xr-xbin/bitbake2
-rw-r--r--lib/bb/__init__.py2
3 files changed, 14 insertions, 2 deletions
diff --git a/ChangeLog b/ChangeLog
index 60faedd53..93cc45aaf 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,15 @@
+Changes in BitBake 1.4.2:
+ - Send logs to oe.pastebin.com instead of pastebin.com
+ fixes #856
+ - Copy the internal bitbake data before building the
+ dependency graph. This fixes nano not having a
+ virtual/libc dependency
+ - Allow multiple TARBALL_STASH entries
+ - Cache, check if the directory exists before changing
+ into it
+ - git speedup cloning by not doing a checkout
+ - allow to have spaces in filenames (.conf, .bb, .bbclass)
+
Changes in BitBake 1.4.0:
- Fix to check both RDEPENDS and RDEPENDS_${PN}
- Fix a RDEPENDS parsing bug in utils:explode_deps()
diff --git a/bin/bitbake b/bin/bitbake
index 22872ac84..3ccd89695 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -31,7 +31,7 @@ import itertools, optparse
parsespin = itertools.cycle( r'|/-\\' )
bbdebug = 0
-__version__ = "1.4.1"
+__version__ = "1.4.2"
#============================================================================#
# BBParsingStatus
diff --git a/lib/bb/__init__.py b/lib/bb/__init__.py
index 08860c409..29805265a 100644
--- a/lib/bb/__init__.py
+++ b/lib/bb/__init__.py
@@ -23,7 +23,7 @@ this program; if not, write to the Free Software Foundation, Inc., 59 Temple
Place, Suite 330, Boston, MA 02111-1307 USA.
"""
-__version__ = "1.4.1"
+__version__ = "1.4.2"
__all__ = [