summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2006-05-03 14:36:50 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2006-05-03 14:36:50 +0000
commit8455c65d7bf180ab065201c129bbd63c32ac25ce (patch)
tree6f8f090b0ae5219b13cc4aaf6a9f4e69215a8cb2
parentff30d3a434fbf0bd34facd104064e2a2553acf7f (diff)
downloadbitbake-8455c65d7bf180ab065201c129bbd63c32ac25ce.tar.gz
bitbake-1.4/bin/bitbake:
- Make the update_data for buildDepGraph act on a copy of self.configuration.data fixing certain dependency errors.
-rwxr-xr-xbin/bitbake6
1 files changed, 4 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 58a973e99..22872ac84 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -701,6 +701,9 @@ class BBCooker:
all_depends = self.status.all_depends
pn_provides = self.status.pn_provides
+ localdata = data.createCopy(self.configuration.data)
+ bb.data.update_data(localdata)
+
def calc_bbfile_priority(filename):
for (regex, pri) in self.status.bbfile_config_priorities:
if regex.match(filename):
@@ -708,7 +711,7 @@ class BBCooker:
return 0
# Handle PREFERRED_PROVIDERS
- for p in (bb.data.getVar('PREFERRED_PROVIDERS', self.configuration.data, 1) or "").split():
+ for p in (bb.data.getVar('PREFERRED_PROVIDERS', localdata, 1) or "").split():
(providee, provider) = p.split(':')
if providee in self.preferred and self.preferred[providee] != provider:
bb.error("conflicting preferences for %s: both %s and %s specified" % (providee, provider, self.preferred[providee]))
@@ -906,7 +909,6 @@ class BBCooker:
print "Requested parsing .bb files only. Exiting."
return
- bb.data.update_data( self.configuration.data )
self.buildDepgraph()
if self.configuration.show_versions: