summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2006-04-29 17:49:49 +0000
committerHolger Hans Peter Freyther <zecke@selfish.org>2006-04-29 17:49:49 +0000
commit66734d7a0d103957add7ad6705f971f3ee874156 (patch)
tree3f8bc363d376e65d704ba74374c2a57f61e7524e
parent5b34f87b8634405363e293d39a64ae5e37bc85c8 (diff)
downloadbitbake-66734d7a0d103957add7ad6705f971f3ee874156.tar.gz
bitbake-1.4/lib/bb/cache.py:
Check directory exists befor chdir this patch was taken from attachment http://bugs.openembedded.org/attachment.cgi?id=691&action=view of bug #918
-rw-r--r--lib/bb/cache.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/bb/cache.py b/lib/bb/cache.py
index e3e0d6a16..921a9f758 100644
--- a/lib/bb/cache.py
+++ b/lib/bb/cache.py
@@ -271,7 +271,8 @@ class Cache:
#data.setVar('TOPDIR', topdir, cfg)
# go there
oldpath = os.path.abspath(os.getcwd())
- os.chdir(topdir)
+ if self.mtime(topdir):
+ os.chdir(topdir)
bb_data = data.init_db(cooker.configuration.data)
try:
parse.handle(bbfile, bb_data) # read .bb data