summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-11 17:38:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-11 17:42:29 +0100
commit3a43dbd286113fa4f5357b81c714223bd466a3c5 (patch)
tree4ff3d8c79c338af90a02c1ee3a7fd1ae3647a684
parenta8a32de0fb74ff63e5490e3b5e4419146a8f7367 (diff)
downloadbitbake-3a43dbd286113fa4f5357b81c714223bd466a3c5.tar.gz
doc: Rename user-manual -> bitbake-user-manual
This manual gets combined with other manuals and in that context, it helps a lot if its seen as the Bitbake User Manual. Renames are a pain but this is worthwhile so that other docs can correctly be combined with this one. This also clarifies things like google search results which is helpful. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--.gitignore6
-rw-r--r--doc/Makefile14
-rw-r--r--doc/README4
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-customization.xsl (renamed from doc/user-manual/user-manual-customization.xsl)0
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-execution.xml (renamed from doc/user-manual/user-manual-execution.xml)4
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-fetching.xml (renamed from doc/user-manual/user-manual-fetching.xml)0
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-hello.xml (renamed from doc/user-manual/user-manual-hello.xml)2
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-intro.xml (renamed from doc/user-manual/user-manual-intro.xml)4
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-metadata.xml (renamed from doc/user-manual/user-manual-metadata.xml)2
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml (renamed from doc/user-manual/user-manual-ref-variables.xml)0
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-style.css (renamed from doc/user-manual/user-manual-style.css)0
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual.xml (renamed from doc/user-manual/user-manual.xml)12
-rw-r--r--doc/bitbake-user-manual/figures/bitbake-title.png (renamed from doc/user-manual/figures/bitbake-title.png)bin5086 -> 5086 bytes
-rw-r--r--doc/bitbake-user-manual/html.css (renamed from doc/user-manual/html.css)0
-rw-r--r--doc/template/titlepage.templates.xml4
15 files changed, 26 insertions, 26 deletions
diff --git a/.gitignore b/.gitignore
index ba767def9..5d9bc50d2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,6 +7,6 @@ pyshtables.py
/bin/bitbakec
*.swp
tags
-doc/user-manual/user-manual.html
-doc/user-manual/user-manual.pdf
-doc/user-manual/user-manual.tgz
+doc/bitbake-user-manual/bitbake-user-manual.html
+doc/bitbake-user-manual/bitbake-user-manual.pdf
+doc/bitbake-user-manual/bitbake-user-manual.tgz
diff --git a/doc/Makefile b/doc/Makefile
index 6b2af6732..8e98c57eb 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -18,21 +18,21 @@
#
# Examples:
#
-# make DOC=user-manual
-# make pdf DOC=user-manual
+# make DOC=bitbake-user-manual
+# make pdf DOC=bitbake-user-manual
#
# The first example generates the HTML and PDF versions of the User Manual.
# The second example generates the HTML version only of the User Manual.
#
-ifeq ($(DOC),user-manual)
-XSLTOPTS = --stringparam html.stylesheet user-manual-style.css \
+ifeq ($(DOC),bitbake-user-manual)
+XSLTOPTS = --stringparam html.stylesheet bitbake-user-manual-style.css \
--stringparam chapter.autolabel 1 \
--stringparam section.autolabel 1 \
--stringparam section.label.includes.component.label 1 \
--xinclude
ALLPREQ = html pdf tarball
-TARFILES = user-manual-style.css user-manual.html user-manual.pdf figures/bitbake-title.png
+TARFILES = bitbake-user-manual-style.css bitbake-user-manual.html bitbake-user-manual.pdf figures/bitbake-title.png
MANUALS = $(DOC)/$(DOC).html $(DOC)/$(DOC).pdf
FIGURES = figures
STYLESHEET = $(DOC)/*.css
@@ -48,7 +48,7 @@ XSL_XHTML_URI = $(XSL_BASE_URI)/xhtml/docbook.xsl
all: $(ALLPREQ)
pdf:
-ifeq ($(DOC),user-manual)
+ifeq ($(DOC),bitbake-user-manual)
@echo " "
@echo "********** Building."$(DOC)
@echo " "
@@ -56,7 +56,7 @@ ifeq ($(DOC),user-manual)
endif
html:
-ifeq ($(DOC),user-manual)
+ifeq ($(DOC),bitbake-user-manual)
# See http://www.sagehill.net/docbookxsl/HtmlOutput.html
@echo " "
@echo "******** Building "$(DOC)
diff --git a/doc/README b/doc/README
index 90aafea9c..303cf8eec 100644
--- a/doc/README
+++ b/doc/README
@@ -8,7 +8,7 @@ Manual Organization
Folders exist for individual manuals as follows:
-* user-manual - The BitBake User Manual
+* bitbake-user-manual - The BitBake User Manual
Each folder is self-contained regarding content and figures.
@@ -28,7 +28,7 @@ For example, the following command run from the documentation directory
creates an HTML and a PDF version of the BitBake User Manual.
The DOC variable specifies the manual you are making:
- $ make DOC=user-manual
+ $ make DOC=bitbake-user-manual
template
========
diff --git a/doc/user-manual/user-manual-customization.xsl b/doc/bitbake-user-manual/bitbake-user-manual-customization.xsl
index a8ec28ae2..a8ec28ae2 100644
--- a/doc/user-manual/user-manual-customization.xsl
+++ b/doc/bitbake-user-manual/bitbake-user-manual-customization.xsl
diff --git a/doc/user-manual/user-manual-execution.xml b/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
index 1cb7fc63c..8514f23f2 100644
--- a/doc/user-manual/user-manual-execution.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
@@ -1,7 +1,7 @@
<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
-<chapter id="user-manual-execution">
+<chapter id="bitbake-user-manual-execution">
<title>Execution</title>
<para>
@@ -24,7 +24,7 @@
</literallayout>
For information on the BitBake command and its options,
see
- "<link linkend='user-manual-command'>The BitBake Command</link>"
+ "<link linkend='bitbake-user-manual-command'>The BitBake Command</link>"
section.
</para>
diff --git a/doc/user-manual/user-manual-fetching.xml b/doc/bitbake-user-manual/bitbake-user-manual-fetching.xml
index 5aa53defc..5aa53defc 100644
--- a/doc/user-manual/user-manual-fetching.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-fetching.xml
diff --git a/doc/user-manual/user-manual-hello.xml b/doc/bitbake-user-manual/bitbake-user-manual-hello.xml
index 5a616e07b..3215e49a2 100644
--- a/doc/user-manual/user-manual-hello.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-hello.xml
@@ -130,7 +130,7 @@
While every attempt is made to explain what is happening,
not everything can be covered.
You can find further information in the
- "<link linkend='user-manual-metadata'>Syntax and Operators</link>"
+ "<link linkend='bitbake-user-manual-metadata'>Syntax and Operators</link>"
chapter.
</para>
diff --git a/doc/user-manual/user-manual-intro.xml b/doc/bitbake-user-manual/bitbake-user-manual-intro.xml
index cd05fc5d0..ae267b42c 100644
--- a/doc/user-manual/user-manual-intro.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-intro.xml
@@ -1,7 +1,7 @@
<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
-<chapter id="user-manual-intro">
+<chapter id="bitbake-user-manual-intro">
<title>Overview</title>
<para>
@@ -417,7 +417,7 @@
</para>
</section>
- <section id="user-manual-command">
+ <section id="bitbake-user-manual-command">
<title>The BitBake Command</title>
<para>
diff --git a/doc/user-manual/user-manual-metadata.xml b/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml
index a57fe0c81..41ae3b8c0 100644
--- a/doc/user-manual/user-manual-metadata.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-metadata.xml
@@ -1,7 +1,7 @@
<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd">
-<chapter id="user-manual-metadata">
+<chapter id="bitbake-user-manual-metadata">
<title>Syntax and Operators</title>
<para>
diff --git a/doc/user-manual/user-manual-ref-variables.xml b/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
index 6a5af89ff..6a5af89ff 100644
--- a/doc/user-manual/user-manual-ref-variables.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-ref-variables.xml
diff --git a/doc/user-manual/user-manual-style.css b/doc/bitbake-user-manual/bitbake-user-manual-style.css
index f7e95f76b..f7e95f76b 100644
--- a/doc/user-manual/user-manual-style.css
+++ b/doc/bitbake-user-manual/bitbake-user-manual-style.css
diff --git a/doc/user-manual/user-manual.xml b/doc/bitbake-user-manual/bitbake-user-manual.xml
index 9f94886c7..e927c4d9e 100644
--- a/doc/user-manual/user-manual.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual.xml
@@ -73,16 +73,16 @@
</legalnotice>
</bookinfo>
- <xi:include href="user-manual-intro.xml"/>
+ <xi:include href="bitbake-user-manual-intro.xml"/>
- <xi:include href="user-manual-execution.xml"/>
+ <xi:include href="bitbake-user-manual-execution.xml"/>
- <xi:include href="user-manual-metadata.xml"/>
+ <xi:include href="bitbake-user-manual-metadata.xml"/>
- <xi:include href="user-manual-fetching.xml"/>
+ <xi:include href="bitbake-user-manual-fetching.xml"/>
- <xi:include href="user-manual-ref-variables.xml"/>
+ <xi:include href="bitbake-user-manual-ref-variables.xml"/>
- <xi:include href="user-manual-hello.xml"/>
+ <xi:include href="bitbake-user-manual-hello.xml"/>
</book>
diff --git a/doc/user-manual/figures/bitbake-title.png b/doc/bitbake-user-manual/figures/bitbake-title.png
index cb290154d..cb290154d 100644
--- a/doc/user-manual/figures/bitbake-title.png
+++ b/doc/bitbake-user-manual/figures/bitbake-title.png
Binary files differ
diff --git a/doc/user-manual/html.css b/doc/bitbake-user-manual/html.css
index 6eedfd318..6eedfd318 100644
--- a/doc/user-manual/html.css
+++ b/doc/bitbake-user-manual/html.css
diff --git a/doc/template/titlepage.templates.xml b/doc/template/titlepage.templates.xml
index 6906604db..38ec11a4c 100644
--- a/doc/template/titlepage.templates.xml
+++ b/doc/template/titlepage.templates.xml
@@ -144,7 +144,7 @@
# If you leave this block of code in then the text title in the
# <title>BitBake User Manual</title> statement of the
-# user-manual.xml file is rendered on the title page below the
+# bitbake-user-manual.xml file is rendered on the title page below the
# image. Commenting it out gets it out of there yet allows it
# to be retained in the tab text for the HTML version of the
# manual.
@@ -176,7 +176,7 @@
<!--
# If you leave this block of code in then the text title in the
# <title>BitBake User Manual</title> statement of the
-# user-manual.xml file is rendered on the title page below the
+# bitbake-user-manual.xml file is rendered on the title page below the
# image. Commenting it out gets it out of there yet allows it
# to be retained in the tab text for the HTML version of the
# manual.