summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-09 10:33:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-09 14:53:04 +0100
commit3c3bd0c2fa80d747f25401c17b785c7c2f3787ca (patch)
treeeb93c7eec09c6cf8c95ab65607d5c386f7842a20
parentea0ca90dba5bbbd84d60b4462f2ca3ff5f880170 (diff)
downloadbitbake-3c3bd0c2fa80d747f25401c17b785c7c2f3787ca.tar.gz
Drop psyco support
At best it gave 1-2% improvement now, its 32 bit x86 only and isn't supported after python 2.6. PyPy is probably a better option now. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rwxr-xr-xbin/bitbake3
-rw-r--r--doc/bitbake.13
-rw-r--r--doc/manual/usermanual.xml2
-rw-r--r--lib/bb/cooker.py13
4 files changed, 0 insertions, 21 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 1ed46d9b5..922a0532f 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -139,9 +139,6 @@ Default BBFILES are the .bb files in the current directory.""")
parser.add_option("-p", "--parse-only", help = "quit after parsing the BB files (developers only)",
action = "store_true", dest = "parse_only", default = False)
- parser.add_option("-d", "--disable-psyco", help = "disable using the psyco just-in-time compiler (not recommended)",
- action = "store_true", dest = "disable_psyco", default = False)
-
parser.add_option("-s", "--show-versions", help = "show current and preferred versions of all packages",
action = "store_true", dest = "show_versions", default = False)
diff --git a/doc/bitbake.1 b/doc/bitbake.1
index 036402e8a..aa096203e 100644
--- a/doc/bitbake.1
+++ b/doc/bitbake.1
@@ -85,9 +85,6 @@ don't execute, just go through the motions
.B \-p, \-\-parse-only
quit after parsing the BB files (developers only)
.TP
-.B \-d, \-\-disable-psyco
-disable using the psyco just-in-time compiler (not recommended)
-.TP
.B \-s, \-\-show-versions
show current and preferred versions of all packages
.TP
diff --git a/doc/manual/usermanual.xml b/doc/manual/usermanual.xml
index a3e85e14f..2ebdf3216 100644
--- a/doc/manual/usermanual.xml
+++ b/doc/manual/usermanual.xml
@@ -417,8 +417,6 @@ options:
than once.
-n, --dry-run don't execute, just go through the motions
-p, --parse-only quit after parsing the BB files (developers only)
- -d, --disable-psyco disable using the psyco just-in-time compiler (not
- recommended)
-s, --show-versions show current and preferred versions of all packages
-e, --environment show the global or per-package environment (this is
what used to be bbread)
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index 86cdd9538..27ca330e4 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -900,19 +900,6 @@ class BBCooker:
if self.state != state.parsing:
self.parseConfiguration ()
- # Import Psyco if available and not disabled
- import platform
- if platform.machine() in ['i386', 'i486', 'i586', 'i686']:
- if not self.configuration.disable_psyco:
- try:
- import psyco
- except ImportError:
- collectlog.info("Psyco JIT Compiler (http://psyco.sf.net) not available. Install it to increase performance.")
- else:
- psyco.bind( CookerParser.parse_next )
- else:
- collectlog.info("You have disabled Psyco. This decreases performance.")
-
self.status = bb.cache.CacheData(self.caches_array)
ignore = bb.data.getVar("ASSUME_PROVIDED", self.configuration.data, 1) or ""