summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-25 23:45:31 +0100
committerChris Larson <chris_larson@mentor.com>2011-08-15 17:17:01 -0700
commit826370e683edb6bfd7cf0b6bf45ee69260517bb8 (patch)
treea67de9132107312464ed66fdfa1848601474d902
parent8f0178ff222e6bd1cd32f1af9396f8536ec50a25 (diff)
downloadbitbake-826370e683edb6bfd7cf0b6bf45ee69260517bb8.tar.gz
cooker.py: Don't show spurious warnings for collections of .bbappend files
Seeing warnings like: WARNING: No bb files matched BBFILE_PATTERN_yocto '^/xxx/meta-yocto/' are not encouraging to users and we shouldn't show these if we found .bbappend files (but no .bb files). This change stops these warnings from appearing. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bb/cooker.py19
1 files changed, 18 insertions, 1 deletions
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index 490fca8cc..4fb313e93 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -424,9 +424,26 @@ class BBCooker:
# Calculate priorities for each file
for p in self.status.pkg_fn:
self.status.bbfile_priority[p] = calc_bbfile_priority(p)
+
+ # Don't show the warning if the BBFILE_PATTERN did match .bbappend files
+ unmatched = set()
+ for _, _, regex, pri in self.status.bbfile_config_priorities:
+ if not regex in matched:
+ unmatched.add(regex)
+
+ def findmatch(regex):
+ for bbfile in self.appendlist:
+ for append in self.appendlist[bbfile]:
+ if regex.match(append):
+ return True
+ return False
+
+ for unmatch in unmatched.copy():
+ if findmatch(unmatch):
+ unmatched.remove(unmatch)
for collection, pattern, regex, _ in self.status.bbfile_config_priorities:
- if not regex in matched:
+ if regex in unmatched:
collectlog.warn("No bb files matched BBFILE_PATTERN_%s '%s'" % (collection, pattern))
def buildWorldTargetList(self):