summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Dike <jdike@linux.intel.com>2010-06-29 13:33:24 +0100
committerChris Larson <chris_larson@mentor.com>2010-08-30 14:44:16 -0700
commit47482fb9f1b925784e748705abdc9fcec2ce374a (patch)
treee0d7caed2556432316094d28aec9f5594f548b25
parentf432c71b34fbb4856fb5d08700b412302e5313da (diff)
downloadbitbake-47482fb9f1b925784e748705abdc9fcec2ce374a.tar.gz
create cooker object after cleaning the environment
Previously, the cooker object was created before the environment was cleaned, saving everything that was in the environment and dumping into the run scripts. The patch ensures that the cooker gets a cleaned environment when it's created. (From Poky rev: 6418d0492a60ed37d13e1060c2e8c09cd127c450) Signed-off-by: Jeff Dike <jdike@linux.intel.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
-rwxr-xr-xbin/bitbake4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 37bed3695..886e7a86e 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -152,13 +152,13 @@ Default BBFILES are the .bb files in the current directory.""" )
# server is daemonized this logfile will be truncated.
cooker_logfile = os.path.join (os.getcwd(), "cooker.log")
- cooker = bb.cooker.BBCooker(configuration, server)
-
# Clear away any spurious environment variables. But don't wipe the
# environment totally. This is necessary to ensure the correct operation
# of the UIs (e.g. for DISPLAY, etc.)
bb.utils.clean_environment()
+ cooker = bb.cooker.BBCooker(configuration, server)
+
cooker.parseCommandLine()
serverinfo = server.BitbakeServerInfo(cooker.server)