summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-11-11 08:42:51 -0700
committerChris Larson <chris_larson@mentor.com>2010-11-11 08:42:53 -0700
commitcc11b9c20e1309f117cfc1c1ab6778cd0f0f2720 (patch)
tree6125811a5de21a259541cf4bb75e21ae595c72a4 /setup.py
parent01b85608d8a37f8af66dfd80133e950120679079 (diff)
downloadbitbake-contrib-cc11b9c20e1309f117cfc1c1ab6778cd0f0f2720.tar.gz
Per Luke Leighton, drop setuptools/ez_setup usage
They are unnecessary for us. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py32
1 files changed, 14 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index 17b304d69..39a41ccc9 100755
--- a/setup.py
+++ b/setup.py
@@ -24,11 +24,7 @@ from bb import __version__
from glob import glob
from distutils.command.clean import clean
from distutils.command.build import build
-
-from ez_setup import use_setuptools
-use_setuptools()
-
-from setuptools import setup, find_packages
+from distutils.core import setup
doctype = "html"
@@ -54,22 +50,22 @@ class Build(build):
os.chdir(origpath)
setup(name='bitbake',
- version=__version__,
- package_dir={"": "lib"},
- packages=find_packages("lib"),
- scripts=["bin/bitbake"],
- # package_data={"bb": ["data"]},
- data_files=[("share/bitbake", glob("conf/*") + glob("classes/*")),
+ version = __version__,
+ package_dir = {"": "lib"},
+ packages = ["bb.server", "bb.parse.parse_py", "bb.parse", "bb.fetch",
+ "bb.ui.crumbs", "bb.ui", "bb", "pysh", "ply"],
+ scripts = ["bin/bitbake"],
+ data_files = [("share/bitbake", glob("conf/*") + glob("classes/*")),
("share/doc/bitbake-%s/manual" % __version__, glob("doc/manual/html/*"))],
- cmdclass={
+ cmdclass = {
"build": Build,
"clean": Clean,
},
- license='GPLv2',
- url='http://developer.berlios.de/projects/bitbake/',
- description='BitBake build tool',
- long_description='BitBake is a simple tool for the execution of tasks. It is derived from Portage, which is the package management system used by the Gentoo Linux distribution. It is most commonly used to build packages, as it can easily use its rudimentary inheritance to abstract common operations, such as fetching sources, unpacking them, patching them, compiling them, and so on. It is the basis of the OpenEmbedded project, which is being used for OpenZaurus, Familiar, and a number of other Linux distributions.',
- author='BitBake Development Team',
- author_email='bitbake-dev@lists.berlios.de',
+ license = 'GPLv2',
+ url = 'http://developer.berlios.de/projects/bitbake/',
+ description = 'BitBake build tool',
+ long_description = 'BitBake is a simple tool for the execution of tasks. It is derived from Portage, which is the package management system used by the Gentoo Linux distribution. It is most commonly used to build packages, as it can easily use its rudimentary inheritance to abstract common operations, such as fetching sources, unpacking them, patching them, compiling them, and so on. It is the basis of the OpenEmbedded project, which is being used for OpenZaurus, Familiar, and a number of other Linux distributions.',
+ author = 'BitBake Development Team',
+ author_email = 'bitbake-dev@lists.berlios.de',
)