summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-11-11 08:43:48 -0700
committerChris Larson <chris_larson@mentor.com>2010-11-11 08:43:48 -0700
commit3be3b9be62bed55f5c44c654f7ce9d9027845f47 (patch)
tree5496c8d1dc443a0080cf494f10249255515e3e2b /setup.py
parentdaa3ffe35997e5fb37da9da9fdd2b7bc3aebe410 (diff)
downloadbitbake-contrib-3be3b9be62bed55f5c44c654f7ce9d9027845f47.tar.gz
Don't ship our own copy of PLY, require it
PLY is publically available, so there's no point in shipping ours. We still retain a local copy, however, so we don't lose the ability to run bitbake in place in the source tree. Signed-off-by: Chris Larson <chris_larson@mentor.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7884b948b..a8d30ab84 100755
--- a/setup.py
+++ b/setup.py
@@ -51,9 +51,10 @@ class Build(build):
setup(name='bitbake',
version = __version__,
+ requires = ["ply"],
package_dir = {"": "lib"},
packages = ["bb.server", "bb.parse.parse_py", "bb.parse", "bb.fetch",
- "bb.ui.crumbs", "bb.ui", "bb", "pysh", "ply"],
+ "bb.ui.crumbs", "bb.ui", "bb", "pysh"],
py_modules = ["codegen"],
scripts = ["bin/bitbake"],
data_files = [("share/bitbake", glob("conf/*") + glob("classes/*")),