aboutsummaryrefslogtreecommitdiffstats
path: root/lib
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2018-09-25 10:58:35 -0400
committerMark Hatle <mark.hatle@windriver.com>2018-09-25 10:58:35 -0400
commitf91e9de40cf9bb0c1108abd74df7c0ef422fa0fe (patch)
tree7298b436cc7445f9e5a4ac4ef5478a6f0a2c142b /lib
parente72be96cfa9f05fda5f420c7cfa8bcfa9304b884 (diff)
downloadbitbake-contrib-f91e9de40cf9bb0c1108abd74df7c0ef422fa0fe.tar.gz
lib/bb/tests/parse.py: Test case was changing chdir
The test case was changing the current directory, but was never restoring it to the original location. This causes occasional failures in later test cases. Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'lib')
-rw-r--r--lib/bb/tests/parse.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/bb/tests/parse.py b/lib/bb/tests/parse.py
index 8f16ba4f4..1bc47405d 100644
--- a/lib/bb/tests/parse.py
+++ b/lib/bb/tests/parse.py
@@ -44,9 +44,13 @@ C = "3"
"""
def setUp(self):
+ self.origdir = os.getcwd()
self.d = bb.data.init()
bb.parse.siggen = bb.siggen.init(self.d)
+ def tearDown(self):
+ os.chdir(self.origdir)
+
def parsehelper(self, content, suffix = ".bb"):
f = tempfile.NamedTemporaryFile(suffix = suffix)