aboutsummaryrefslogtreecommitdiffstats
path: root/lib/layerindexlib/tests/testdata/layer3/conf/layer.conf
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2018-07-23 22:29:11 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-01 10:07:27 +0100
commitfd0ee6c10dbb5592731e56f4c592fe687682a3e6 (patch)
tree639b00e54beb354cf477777b49bce5f3cad5ee8e /lib/layerindexlib/tests/testdata/layer3/conf/layer.conf
parent8aeaabf13db645f33495e00b82117327e153d70a (diff)
downloadbitbake-contrib-fd0ee6c10dbb5592731e56f4c592fe687682a3e6.tar.gz
layerindexlib: Initial layer index processing module implementation
The layer index module is expected to be used by various parts of the system in order to access a layerindex-web (such as layers.openembedded.org) and perform basic processing on the information, such as dependency scanning. Along with the layerindex implementation are associated tests. The tests properly honor BB_SKIP_NETTESTS='yes' to prevent test failures. Tests Implemented: - Branch, LayerItem, LayerBranch, LayerDependency, Recipe, Machine and Distro objects - LayerIndex setup using the layers.openembedded.org restapi - LayerIndex storing and retrieving from a file - LayerIndex verify dependency resolution ordering - LayerIndex setup using simulated cooker data Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/layerindexlib/tests/testdata/layer3/conf/layer.conf')
-rw-r--r--lib/layerindexlib/tests/testdata/layer3/conf/layer.conf19
1 files changed, 19 insertions, 0 deletions
diff --git a/lib/layerindexlib/tests/testdata/layer3/conf/layer.conf b/lib/layerindexlib/tests/testdata/layer3/conf/layer.conf
new file mode 100644
index 000000000..7089071fa
--- /dev/null
+++ b/lib/layerindexlib/tests/testdata/layer3/conf/layer.conf
@@ -0,0 +1,19 @@
+# We might have a conf and classes directory, append to BBPATH
+BBPATH .= ":${LAYERDIR}"
+
+# We have recipes directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "meta-python"
+BBFILE_PATTERN_meta-python := "^${LAYERDIR}/"
+BBFILE_PRIORITY_meta-python = "7"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_meta-python = "1"
+
+LAYERDEPENDS_meta-python = "core openembedded-layer"
+
+LAYERSERIES_COMPAT_meta-python = "sumo"
+
+LICENSE_PATH += "${LAYERDIR}/licenses"