aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/tests/runqueue-tests/conf/bitbake.conf
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2020-06-05 22:15:35 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-08 21:33:27 +0100
commit513fc2dddf13d5e344162c26d89d2dde2fe85634 (patch)
tree461f619beea39298570792063106da6b1e91fbca /lib/bb/tests/runqueue-tests/conf/bitbake.conf
parent3c5c7346adf4ca7ec761c08738f12401ba75b7c8 (diff)
downloadbitbake-contrib-513fc2dddf13d5e344162c26d89d2dde2fe85634.tar.gz
bitbake: tests: Add tests for BBMASK in multiconfig
Adds a test to validate that multiconfigs can independently mask off recipes by setting BBMASK. See the test description for further information about how the test works. Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/tests/runqueue-tests/conf/bitbake.conf')
-rw-r--r--lib/bb/tests/runqueue-tests/conf/bitbake.conf3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/bb/tests/runqueue-tests/conf/bitbake.conf b/lib/bb/tests/runqueue-tests/conf/bitbake.conf
index 5e451fc2c..efebf001a 100644
--- a/lib/bb/tests/runqueue-tests/conf/bitbake.conf
+++ b/lib/bb/tests/runqueue-tests/conf/bitbake.conf
@@ -1,7 +1,8 @@
CACHE = "${TOPDIR}/cache"
THISDIR = "${@os.path.dirname(d.getVar('FILE'))}"
COREBASE := "${@os.path.normpath(os.path.dirname(d.getVar('FILE')+'/../../'))}"
-BBFILES = "${COREBASE}/recipes/*.bb"
+EXTRA_BBFILES ?= ""
+BBFILES = "${COREBASE}/recipes/*.bb ${EXTRA_BBFILES}"
PROVIDES = "${PN}"
PN = "${@bb.parse.vars_from_file(d.getVar('FILE', False),d)[0]}"
PF = "${BB_CURRENT_MC}:${PN}"