summaryrefslogtreecommitdiffstats
path: root/doc
diff options
context:
space:
mode:
authorRobert P. J. Day <rpjday@crashcourse.ca>2014-07-08 21:58:42 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-21 11:00:35 +0100
commit8ff1b363df74f7e48da67fce9cf6b7e868c5e28e (patch)
treeead7c75c9e92a46045d02974bb3dae92d6b0d8dc /doc
parentaf98b2ff4f44f892b63a6598e7fdfc144972ed3d (diff)
downloadbitbake-contrib-8ff1b363df74f7e48da67fce9cf6b7e868c5e28e.tar.gz
bitbake-user-manual-execution.xml: Minor edits to execution chapter.
Signed-off-by: Scott Rifenbark <scott.m.rifenbark@intel.com>
Diffstat (limited to 'doc')
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-execution.xml31
1 files changed, 30 insertions, 1 deletions
diff --git a/doc/bitbake-user-manual/bitbake-user-manual-execution.xml b/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
index 8b6e0b442..571424b99 100644
--- a/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
+++ b/doc/bitbake-user-manual/bitbake-user-manual-execution.xml
@@ -7,7 +7,8 @@
<para>
The primary purpose for running BitBake is to produce some kind
of output such as a single installable package, a kernel, a software
- development kit, or even a full, board-specific bootable Linux image.
+ development kit, or even a full, board-specific bootable Linux image,
+ complete with bootloader, kernel, and root filesystem.
Of course, you can execute the <filename>bitbake</filename>
command with options that cause it to execute single tasks,
compile single recipe files, capture or clear data, or simply
@@ -45,6 +46,11 @@
build host with hyper-threading will most likely show eight processors,
which is the value you would then assign to that variable.
</para>
+
+ <para>
+ A possibly simpler solution is that some Linux distributions
+ (e.g. Debian and Ubuntu) provide the <filename>ncpus</filename> command.
+ </para>
</note>
</para>
@@ -464,6 +470,29 @@
PREFERRED_VERSION_a = "1.1"
</literallayout>
</para>
+
+ <note>
+ <para>
+ It is common for a recipe to provide two versions -- a stable,
+ numbered (and preferred) version, and a version that is
+ automatically checked out from a source code repository that
+ is considered more "bleeding edge" but can be selected only
+ explicitly.
+ </para>
+
+ <para>
+ For example, in the OpenEmbedded codebase, there is a standard,
+ versioned recipe file for BusyBox,
+ <filename>busybox_1.22.1.bb</filename>,
+ but there is also a Git-based version,
+ <filename>busybox_git.bb</filename>, which explicitly contains the line
+ <literallayout class='monospaced'>
+ DEFAULT_PREFERENCE = "-1"
+ </literallayout>
+ to ensure that the numbered, stable version is always preferred
+ unless the developer selects otherwise.
+ </para>
+ </note>
</section>
<section id='bb-bitbake-dependencies'>