summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2014-05-23 16:22:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-05-28 08:27:40 +0100
commit5569b3dca61e6d962494ca65c7aad09b2eb2ae63 (patch)
treed980e5a39ac3b18e294f46de0a577c74f9937b65 /bin
parentb94318174fe7f92b9a20eabb0bc4055066cb3d51 (diff)
downloadbitbake-contrib-5569b3dca61e6d962494ca65c7aad09b2eb2ae63.tar.gz
bitbake-layers: show-cross-depends: add support for RRECOMMENDS
RRECOMMENDS must be satisfied at build time, and these could cross layer boundaries, so report these if they exist. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake-layers20
1 files changed, 20 insertions, 0 deletions
diff --git a/bin/bitbake-layers b/bin/bitbake-layers
index 135096bce..302f020ba 100755
--- a/bin/bitbake-layers
+++ b/bin/bitbake-layers
@@ -634,6 +634,26 @@ The .bbappend file can impact the dependency.
self.bbhandler.cooker_data)[0][0]
self.check_cross_depends("RDEPENDS", layername, f, best, options.show_filenames, ignore_layers)
+ # The RRECOMMENDS
+ all_rrecs = self.bbhandler.cooker_data.runrecs[f].values()
+ # Remove the duplicated or null one.
+ sorted_rrecs = {}
+ # The all_rrecs is the list in list, so we need two for loops
+ for k1 in all_rrecs:
+ for k2 in k1:
+ sorted_rrecs[k2] = 1
+ all_rrecs = sorted_rrecs.keys()
+ for rrec in all_rrecs:
+ all_p = bb.providers.getRuntimeProviders(self.bbhandler.cooker_data, rrec)
+ if all_p:
+ if f in all_p:
+ # The recipe provides this one itself, ignore
+ continue
+ best = bb.providers.filterProvidersRunTime(all_p, rrec,
+ self.bbhandler.config_data,
+ self.bbhandler.cooker_data)[0][0]
+ self.check_cross_depends("RRECOMMENDS", layername, f, best, options.show_filenames, ignore_layers)
+
# The inherit class
cls_re = re.compile('classes/')
if f in self.bbhandler.cooker_data.inherits: