aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2020-10-05 14:19:32 +0200
committerNicolas Dechesne <nicolas.dechesne@linaro.org>2020-10-05 14:19:32 +0200
commit9ae5cce76693d7c12396cee1183aaf371bb3d66c (patch)
tree515b96520ce09d6d1cead148c5bf7717f1dae32b
parentec4c481a0c3a3ccd0ef0832f128afdc047876552 (diff)
downloadbitbake-contrib-9ae5cce76693d7c12396cee1183aaf371bb3d66c.tar.gz
docs: sphinx: report errors when dependencies are not met
Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
-rw-r--r--doc/Makefile.sphinx4
-rw-r--r--doc/conf.py8
2 files changed, 11 insertions, 1 deletions
diff --git a/doc/Makefile.sphinx b/doc/Makefile.sphinx
index c663c2954..c9518558b 100644
--- a/doc/Makefile.sphinx
+++ b/doc/Makefile.sphinx
@@ -9,6 +9,10 @@ SOURCEDIR = .
BUILDDIR = _build
DESTDIR = final
+ifeq ($(shell if which $(SPHINXBUILD) >/dev/null 2>&1; then echo 1; else echo 0; fi),0)
+$(error "The '$(SPHINXBUILD)' command was not found. Make sure you have Sphinx installed")
+endif
+
# Put it first so that "make" without argument is like "make help".
help:
@$(SPHINXBUILD) -M help "$(SOURCEDIR)" "$(BUILDDIR)" $(SPHINXOPTS) $(O)
diff --git a/doc/conf.py b/doc/conf.py
index 197f2757a..354dff36f 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -73,7 +73,13 @@ rst_prolog = """
# The theme to use for HTML and HTML Help pages. See the documentation for
# a list of builtin themes.
#
-html_theme = 'sphinx_rtd_theme'
+try:
+ import sphinx_rtd_theme
+ html_theme = 'sphinx_rtd_theme'
+except ImportError:
+ sys.stderr.write("The Sphinx sphinx_rtd_theme HTML theme was not found.\
+ \nPlease make sure to install the sphinx_rtd_theme python package.\n")
+ sys.exit(1)
# Add any paths that contain custom static files (such as style sheets) here,
# relative to this directory. They are copied after the builtin static files,