aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-10-19 10:06:11 -1000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-23 17:47:26 +0100
commitd5ac4af74ba62a27232ff16931e8f3b22fc43112 (patch)
treebc9cb7991df66b3d8bcccfad77a379d929f75bba
parent4b66d498eab22eca29c9e3a7fdfa5c6e54055e78 (diff)
downloadbitbake-contrib-d5ac4af74ba62a27232ff16931e8f3b22fc43112.tar.gz
bitbake: fix regexp deprecation warnings
See here for details: https://docs.python.org/3/library/re.html Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 660e6ad4abb77c6f3c1d48bd64777dd76c05d7e2) Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--lib/bblayers/query.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/bblayers/query.py b/lib/bblayers/query.py
index fb6f550ec..652a3acce 100644
--- a/lib/bblayers/query.py
+++ b/lib/bblayers/query.py
@@ -433,10 +433,10 @@ NOTE: .bbappend files can impact the dependencies.
line = fnfile.readline()
# The "require/include xxx" in conf/machine/*.conf, .inc and .bbclass
- conf_re = re.compile(".*/conf/machine/[^\/]*\.conf$")
- inc_re = re.compile(".*\.inc$")
+ conf_re = re.compile(r".*/conf/machine/[^\/]*\.conf$")
+ inc_re = re.compile(r".*\.inc$")
# The "inherit xxx" in .bbclass
- bbclass_re = re.compile(".*\.bbclass$")
+ bbclass_re = re.compile(r".*\.bbclass$")
for layerdir in self.bblayers:
layername = self.get_layer_name(layerdir)
for dirpath, dirnames, filenames in os.walk(layerdir):