aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/freesmartphone/fso-alsa_git.bb6
-rw-r--r--recipes/freesmartphone/libframeworkd-glib_git.bb7
-rw-r--r--recipes/freesmartphone/libfso-glib_git.bb6
-rw-r--r--recipes/freesmartphone/libgsm0710_git.bb2
-rw-r--r--recipes/freesmartphone/libgsm0710mux_git.bb2
-rw-r--r--recipes/freesmartphone/libpersistence_git.bb2
-rw-r--r--recipes/freesmartphone/mdbus2_git.bb6
-rw-r--r--recipes/freesmartphone/mioctl_git.bb4
-rw-r--r--recipes/freesmartphone/mkdump_git.bb5
-rw-r--r--recipes/freesmartphone/msmcommd_git.bb5
-rw-r--r--recipes/freesmartphone/mterm2_git.bb4
-rw-r--r--recipes/freesmartphone/zhone2_git.bb2
12 files changed, 42 insertions, 9 deletions
diff --git a/recipes/freesmartphone/fso-alsa_git.bb b/recipes/freesmartphone/fso-alsa_git.bb
index b83613e7f0..8f5e173bdd 100644
--- a/recipes/freesmartphone/fso-alsa_git.bb
+++ b/recipes/freesmartphone/fso-alsa_git.bb
@@ -11,4 +11,8 @@ PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
S = "${WORKDIR}/git/tools/fso-alsa"
-inherit autotools vala
+do_stage() {
+ :
+}
+
+inherit autotools_stage vala
diff --git a/recipes/freesmartphone/libframeworkd-glib_git.bb b/recipes/freesmartphone/libframeworkd-glib_git.bb
index 21cab5dd31..5fa47d835f 100644
--- a/recipes/freesmartphone/libframeworkd-glib_git.bb
+++ b/recipes/freesmartphone/libframeworkd-glib_git.bb
@@ -10,4 +10,9 @@ PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/libframeworkd-glib.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
-inherit autotools
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/freesmartphone/libfso-glib_git.bb b/recipes/freesmartphone/libfso-glib_git.bb
index d7de0525ce..8984741be7 100644
--- a/recipes/freesmartphone/libfso-glib_git.bb
+++ b/recipes/freesmartphone/libfso-glib_git.bb
@@ -8,7 +8,11 @@ PV = "0.2.2+gitr${SRCPV}"
PE = "1"
PR = "r4"
-inherit autotools vala
+inherit autotools_stage pkgconfig vala
+
+PARALLEL_MAKE = ""
SRC_URI = "${FREESMARTPHONE_GIT}/libfso-glib.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
+
+FILES_${PN}-dev += "${datadir}/gir-1.0/*.gir"
diff --git a/recipes/freesmartphone/libgsm0710_git.bb b/recipes/freesmartphone/libgsm0710_git.bb
index 2c78789d9b..6b78c9f922 100644
--- a/recipes/freesmartphone/libgsm0710_git.bb
+++ b/recipes/freesmartphone/libgsm0710_git.bb
@@ -9,4 +9,4 @@ PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/libgsm0710.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
-inherit autotools vala
+inherit autotools_stage pkgconfig vala
diff --git a/recipes/freesmartphone/libgsm0710mux_git.bb b/recipes/freesmartphone/libgsm0710mux_git.bb
index fe94d21fdd..f85be3c238 100644
--- a/recipes/freesmartphone/libgsm0710mux_git.bb
+++ b/recipes/freesmartphone/libgsm0710mux_git.bb
@@ -11,4 +11,4 @@ PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
S = "${WORKDIR}/git/libgsm0710mux"
-inherit autotools vala
+inherit autotools_stage pkgconfig vala
diff --git a/recipes/freesmartphone/libpersistence_git.bb b/recipes/freesmartphone/libpersistence_git.bb
index ab1892e246..0550045aed 100644
--- a/recipes/freesmartphone/libpersistence_git.bb
+++ b/recipes/freesmartphone/libpersistence_git.bb
@@ -13,4 +13,4 @@ SRC_URI = "\
"
S = "${WORKDIR}/git"
-inherit autotools vala
+inherit autotools_stage pkgconfig vala
diff --git a/recipes/freesmartphone/mdbus2_git.bb b/recipes/freesmartphone/mdbus2_git.bb
index dd0336c60c..76af519d4b 100644
--- a/recipes/freesmartphone/mdbus2_git.bb
+++ b/recipes/freesmartphone/mdbus2_git.bb
@@ -12,4 +12,8 @@ PE = "1"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
S = "${WORKDIR}/git/tools/mdbus2"
-inherit autotools vala
+do_stage() {
+ :
+}
+
+inherit autotools_stage vala
diff --git a/recipes/freesmartphone/mioctl_git.bb b/recipes/freesmartphone/mioctl_git.bb
index e09c424b51..56bb1c42af 100644
--- a/recipes/freesmartphone/mioctl_git.bb
+++ b/recipes/freesmartphone/mioctl_git.bb
@@ -10,4 +10,8 @@ PR = "r0"
SRC_URI = "${FREESMARTPHONE_GIT}/cornucopia.git;protocol=git;branch=master"
S = "${WORKDIR}/git/tools/mioctl"
+do_stage() {
+ :
+}
+
inherit autotools vala
diff --git a/recipes/freesmartphone/mkdump_git.bb b/recipes/freesmartphone/mkdump_git.bb
index b31f896a7d..4d7be38947 100644
--- a/recipes/freesmartphone/mkdump_git.bb
+++ b/recipes/freesmartphone/mkdump_git.bb
@@ -16,3 +16,8 @@ SRC_URI = "\
S = "${WORKDIR}/git/tools/mkdump"
inherit autotools vala
+
+do_stage() {
+ :
+}
+
diff --git a/recipes/freesmartphone/msmcommd_git.bb b/recipes/freesmartphone/msmcommd_git.bb
index 5330792d54..7177e50fc1 100644
--- a/recipes/freesmartphone/msmcommd_git.bb
+++ b/recipes/freesmartphone/msmcommd_git.bb
@@ -12,8 +12,11 @@ PE = "1"
SRC_URI = "${FREESMARTPHONE_GIT}/msmcomm.git;protocol=git;branch=master"
S = "${WORKDIR}/git"
-inherit autotools vala
+inherit autotools_stage vala
+
+PARALLEL_MAKE = ""
PACKAGES =+ "${PN}-lib ${PN}-term"
FILES_${PN}-lib = "${libdir}/lib*.so.*"
FILES_${PN}-term = "${sbindir}/msmvterm"
+
diff --git a/recipes/freesmartphone/mterm2_git.bb b/recipes/freesmartphone/mterm2_git.bb
index a99f848f39..f459a4ab65 100644
--- a/recipes/freesmartphone/mterm2_git.bb
+++ b/recipes/freesmartphone/mterm2_git.bb
@@ -14,6 +14,10 @@ SRC_URI = "\
"
S = "${WORKDIR}/git/tools/mterm2"
+do_stage() {
+ :
+}
+
inherit autotools vala
FILES_${PN} += "${datadir}"
diff --git a/recipes/freesmartphone/zhone2_git.bb b/recipes/freesmartphone/zhone2_git.bb
index 78a533be02..11402b4649 100644
--- a/recipes/freesmartphone/zhone2_git.bb
+++ b/recipes/freesmartphone/zhone2_git.bb
@@ -18,7 +18,7 @@ SRC_URI[splash.md5sum] = "e198d5c83cc47a216562e435df0e03c3"
SRC_URI[splash.sha256sum] = "3e41bcf4ea50ab7406d3833e412a78ddb9afaab4b0a8cca1bf93755d1ce9a215"
S = "${WORKDIR}/git/zhone2"
-inherit autotools update-rc.d
+inherit autotools_stage update-rc.d
INITSCRIPT_NAME = "zhone2"
INITSCRIPT_PARAMS = "defaults 40"