aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/zope
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/zope')
-rw-r--r--recipes/zope/python-zopeinterface_3.5.1.bb22
1 files changed, 13 insertions, 9 deletions
diff --git a/recipes/zope/python-zopeinterface_3.5.1.bb b/recipes/zope/python-zopeinterface_3.5.1.bb
index c0d3f60016..126775622e 100644
--- a/recipes/zope/python-zopeinterface_3.5.1.bb
+++ b/recipes/zope/python-zopeinterface_3.5.1.bb
@@ -2,17 +2,21 @@ DESCRIPTION = "Interface definitions for Zope products"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "ZPL"
-
-RPROVIDES_${PN} += " zope-interfaces"
-
-inherit distutils
-
-PR = "r1"
+RPROVIDES_${PN} += "zope-interfaces"
+PR = "r2"
SRC_URI = "http://pypi.python.org/packages/source/z/zope.interface/zope.interface-${PV}.tar.gz"
+SRC_URI[md5sum] = "685fc532550abb07cca6190c9cd2b901"
+SRC_URI[sha256sum] = "b81d898532c47f73475c2d0c23580e289eed25923d007eca8e62750c0998bba0"
+
S = "${WORKDIR}/zope.interface-${PV}"
-FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
+inherit setuptools
-SRC_URI[md5sum] = "685fc532550abb07cca6190c9cd2b901"
-SRC_URI[sha256sum] = "b81d898532c47f73475c2d0c23580e289eed25923d007eca8e62750c0998bba0"
+FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
+FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
+FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
+FILES_${PN}-tests = " \
+ ${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
+ ${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
+"