aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/tilibs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/tilibs')
-rw-r--r--recipes/tilibs/libticables_3.9.2.bb10
-rw-r--r--recipes/tilibs/libticalcs_4.5.9.bb13
-rw-r--r--recipes/tilibs/libtifiles_0.6.5.bb11
3 files changed, 34 insertions, 0 deletions
diff --git a/recipes/tilibs/libticables_3.9.2.bb b/recipes/tilibs/libticables_3.9.2.bb
new file mode 100644
index 0000000000..a9c785c15f
--- /dev/null
+++ b/recipes/tilibs/libticables_3.9.2.bb
@@ -0,0 +1,10 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://lpg.ticalc.org/prj_tilp/index.html"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tilp/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+autotools_stage_all
+}
diff --git a/recipes/tilibs/libticalcs_4.5.9.bb b/recipes/tilibs/libticalcs_4.5.9.bb
new file mode 100644
index 0000000000..0a2b8f6f57
--- /dev/null
+++ b/recipes/tilibs/libticalcs_4.5.9.bb
@@ -0,0 +1,13 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://lpg.ticalc.org/prj_tilp/index.html"
+
+DPENDS = "libticables libtifiles"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tilp/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+autotools_stage_all
+}
+
diff --git a/recipes/tilibs/libtifiles_0.6.5.bb b/recipes/tilibs/libtifiles_0.6.5.bb
new file mode 100644
index 0000000000..5ac2701d9a
--- /dev/null
+++ b/recipes/tilibs/libtifiles_0.6.5.bb
@@ -0,0 +1,11 @@
+LICENSE = "GPLv2"
+HOMEPAGE = "http://lpg.ticalc.org/prj_tilp/index.html"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/tilp/${P}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+autotools_stage_all
+}
+