aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openssl/openssl-1.0.0e/debian/pkg-config.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openssl/openssl-1.0.0e/debian/pkg-config.patch')
-rw-r--r--recipes/openssl/openssl-1.0.0e/debian/pkg-config.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/openssl/openssl-1.0.0e/debian/pkg-config.patch b/recipes/openssl/openssl-1.0.0e/debian/pkg-config.patch
new file mode 100644
index 0000000000..7a2a94e120
--- /dev/null
+++ b/recipes/openssl/openssl-1.0.0e/debian/pkg-config.patch
@@ -0,0 +1,34 @@
+Index: openssl-1.0.0c/Makefile.org
+===================================================================
+--- openssl-1.0.0c.orig/Makefile.org 2010-12-12 16:13:28.000000000 +0100
++++ openssl-1.0.0c/Makefile.org 2010-12-12 17:01:49.000000000 +0100
+@@ -323,7 +323,8 @@
+ echo 'Description: OpenSSL cryptography library'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lcrypto'; \
++ echo 'Libs.private: $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libcrypto.pc
+
+ libssl.pc: Makefile
+@@ -336,7 +337,8 @@
+ echo 'Description: Secure Sockets Layer and cryptography libraries'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lssl'; \
++ echo 'Libs.private: -lcrypto $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libssl.pc
+
+ openssl.pc: Makefile
+@@ -349,7 +351,8 @@
+ echo 'Description: Secure Sockets Layer and cryptography libraries and tools'; \
+ echo 'Version: '$(VERSION); \
+ echo 'Requires: '; \
+- echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
++ echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
++ echo 'Libs.private: $(EX_LIBS)'; \
+ echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
+
+ Makefile: Makefile.org Configure config