aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lmbench
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lmbench')
-rw-r--r--recipes/lmbench/lmbench_2.0.4.bb6
-rw-r--r--recipes/lmbench/lmbench_2.5.bb6
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes/lmbench/lmbench_2.0.4.bb b/recipes/lmbench/lmbench_2.0.4.bb
index ba96820463..fc6c7a13dc 100644
--- a/recipes/lmbench/lmbench_2.0.4.bb
+++ b/recipes/lmbench/lmbench_2.0.4.bb
@@ -14,6 +14,12 @@ EXTRA_OEMAKE = '"CC=${CC}" "AR=${AR}" "CFLAGS=$CFLAGS" \
"LDFLAGS=${LDFLAGS}" "LD=${LD}" "OS=${TARGET_SYS}" \
"TARGET=${TARGET_OS}" "O=${S}/bin/${TARGET_SYS}"'
+
+inherit siteinfo
+
+# Space separated list of shell scripts with variables defined to supply test
+# results for autoconf tests we cannot run at build time.
+export CONFIG_SITE = "${@siteinfo_get_files(d)}"
python do_unpack () {
bb.build.exec_func('base_do_unpack', d)
bb.build.exec_func('byebk_do_unpack', d)
diff --git a/recipes/lmbench/lmbench_2.5.bb b/recipes/lmbench/lmbench_2.5.bb
index cac96b474e..80f53a8a3f 100644
--- a/recipes/lmbench/lmbench_2.5.bb
+++ b/recipes/lmbench/lmbench_2.5.bb
@@ -13,6 +13,12 @@ EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" LD="${LD}" OS="${TARGET_SYS}" \
TARGET="${TARGET_OS}" BASE="${prefix}"'
+
+inherit siteinfo
+
+# Space separated list of shell scripts with variables defined to supply test
+# results for autoconf tests we cannot run at build time.
+export CONFIG_SITE = "${@siteinfo_get_files(d)}"
python do_unpack () {
bb.build.exec_func('base_do_unpack', d)
bb.build.exec_func('byebk_do_unpack', d)