aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lmbench/lmbench_2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lmbench/lmbench_2.5.bb')
-rw-r--r--recipes/lmbench/lmbench_2.5.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes/lmbench/lmbench_2.5.bb b/recipes/lmbench/lmbench_2.5.bb
index cac96b474e..80f53a8a3f 100644
--- a/recipes/lmbench/lmbench_2.5.bb
+++ b/recipes/lmbench/lmbench_2.5.bb
@@ -13,6 +13,12 @@ EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" CFLAGS="${CFLAGS}" \
LDFLAGS="${LDFLAGS}" LD="${LD}" OS="${TARGET_SYS}" \
TARGET="${TARGET_OS}" BASE="${prefix}"'
+
+inherit siteinfo
+
+# Space separated list of shell scripts with variables defined to supply test
+# results for autoconf tests we cannot run at build time.
+export CONFIG_SITE = "${@siteinfo_get_files(d)}"
python do_unpack () {
bb.build.exec_func('base_do_unpack', d)
bb.build.exec_func('byebk_do_unpack', d)