aboutsummaryrefslogtreecommitdiffstats
path: root/packages/classpath
diff options
context:
space:
mode:
Diffstat (limited to 'packages/classpath')
-rw-r--r--packages/classpath/classpath-initial_0.93.bb7
-rw-r--r--packages/classpath/files/miscompilation-0.93.patch13
2 files changed, 18 insertions, 2 deletions
diff --git a/packages/classpath/classpath-initial_0.93.bb b/packages/classpath/classpath-initial_0.93.bb
index 5a471b3808..c36ea3813d 100644
--- a/packages/classpath/classpath-initial_0.93.bb
+++ b/packages/classpath/classpath-initial_0.93.bb
@@ -5,11 +5,14 @@ require classpath-native.inc
DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
-PR = "r4"
+PR = "r6"
DEPENDS = "zip-native fastjar-native jikes-native gettext-native"
-SRC_URI += "file://autotools.patch;patch=1"
+SRC_URI += "\
+ file://autotools.patch;patch=1 \
+ file://miscompilation-0.93.patch;patch=1 \
+ "
EXTRA_OECONF = "\
--with-jikes=jikes \
diff --git a/packages/classpath/files/miscompilation-0.93.patch b/packages/classpath/files/miscompilation-0.93.patch
new file mode 100644
index 0000000000..99db6f3003
--- /dev/null
+++ b/packages/classpath/files/miscompilation-0.93.patch
@@ -0,0 +1,13 @@
+Index: classpath-0.93/native/jni/java-io/java_io_VMFile.c
+===================================================================
+--- classpath-0.93.orig/native/jni/java-io/java_io_VMFile.c 2006-09-23 07:17:45.000000000 +0200
++++ classpath-0.93/native/jni/java-io/java_io_VMFile.c 2008-11-14 13:41:27.000000000 +0100
+@@ -239,7 +239,7 @@
+ {
+ #ifndef WITHOUT_FILESYSTEM
+ const char *filename;
+- int result;
++ volatile int result;
+
+ /* Don't use the JCL convert function because it throws an exception
+ on failure */