aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
Diffstat (limited to 'classes')
-rw-r--r--classes/mozilla.bbclass16
1 files changed, 8 insertions, 8 deletions
diff --git a/classes/mozilla.bbclass b/classes/mozilla.bbclass
index 2b2f770d58..6d9492cfd6 100644
--- a/classes/mozilla.bbclass
+++ b/classes/mozilla.bbclass
@@ -26,6 +26,14 @@ export HOST_CXXFLAGS = "${BUILD_CXXFLAGS}"
export HOST_LDFLAGS = "${BUILD_LDFLAGS}"
export HOST_RANLIB = "${BUILD_RANLIB}"
export HOST_AR = "${BUILD_AR}"
+# Set the host libIDL stuff correctly.
+export HOST_LIBIDL_CONFIG="PKG_CONFIG_PATH=${STAGING_LIBDIR_NATIVE}/pkgconfig pkg-config libIDL-2.0"
+# Due to sysroot we need to sed out references to the target staging
+# when building the native version of xpidl Symptons of the failure
+# include "gthread.h:344: error: size of array 'type name' is negative"
+export HOST_LIBIDL_CFLAGS="`${HOST_LIBIDL_CONFIG} --cflags | sed -e s:${STAGING_DIR_TARGET}::g`"
+export HOST_LIBIDL_LIBS="`${HOST_LIBIDL_CONFIG} --libs`"
+
mozilla_do_configure() {
(
@@ -44,14 +52,6 @@ mozilla_do_configure() {
>> ${MOZCONFIG}
fi
- # Set the host libIDL stuff correctly.
- export HOST_LIBIDL_CONFIG="PKG_CONFIG_PATH=${STAGING_LIBDIR_NATIVE}/pkgconfig pkg-config libIDL-2.0"
- # Due to sysroot we need to sed out references to the target staging
- # when building the native version of xpidl Symptons of the failure
- # include "gthread.h:344: error: size of array 'type name' is negative"
- export HOST_LIBIDL_CFLAGS="`${HOST_LIBIDL_CONFIG} --cflags | sed -e s:${STAGING_DIR_TARGET}:${STAGING_DIR_NATIVE}:g`"
- export HOST_LIBIDL_LIBS="`${HOST_LIBIDL_CONFIG} --libs`"
-
if [ -e ${MOZ_OBJDIR}/Makefile ] ; then
oe_runmake -f client.mk ${MOZ_OBJDIR}/Makefile \
${MOZ_OBJDIR}/config.status