aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/e17/enna_svn.bb15
-rw-r--r--recipes/enna/enna.inc16
-rw-r--r--recipes/enna/enna_hg.bb9
3 files changed, 25 insertions, 15 deletions
diff --git a/recipes/e17/enna_svn.bb b/recipes/e17/enna_svn.bb
deleted file mode 100644
index f81990cd1a..0000000000
--- a/recipes/e17/enna_svn.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DESCRIPTION = "Enna is a media center application based on EFL"
-LICENSE = "GPL"
-DEPENDS = "curl dbus eet evas edje ecore edbus emotion"
-DEPENDS += "libmusicbrainz lightmediascanner libxml2 taglib"
-SECTION = "x11/multimedia"
-PV = "0.2.0+svnr${SRCPV}"
-PR = "r1"
-SRCREV = "${EFL_SRCREV}"
-
-inherit e
-
-SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk/MISC;module=enna;proto=http"
-S = "${WORKDIR}/enna"
-
-FILES_${PN}-dbg += "${libdir}/${PN}/modules/.debug"
diff --git a/recipes/enna/enna.inc b/recipes/enna/enna.inc
new file mode 100644
index 0000000000..4cc5b481cc
--- /dev/null
+++ b/recipes/enna/enna.inc
@@ -0,0 +1,16 @@
+DESCRIPTION = "Enna is a media center application based on EFL."
+HOMEPAGE = "http://${PN}.geexbox.org/"
+SECTION = "x11/multimedia"
+LICENSE = "LGPLv2.1+"
+DEPENDS = "curl eet evas edje ecore edbus elementary emotion"
+DEPENDS += "libxml2 libvalhalla libplayer"
+
+INC_PR = "r1"
+
+SRC_URI = "http://${PN}.geexbox.org/releases/${P}.tar.bz2;name=${PN}"
+
+inherit autotools pkgconfig
+
+do_configure_prepend() {
+ autopoint || touch config.rpath
+}
diff --git a/recipes/enna/enna_hg.bb b/recipes/enna/enna_hg.bb
new file mode 100644
index 0000000000..89fa12b488
--- /dev/null
+++ b/recipes/enna/enna_hg.bb
@@ -0,0 +1,9 @@
+require enna.inc
+PV = "0.4.0+hg"
+PR = "${INC_PR}.0"
+
+SRCREV = "2a9c5f249b47"
+
+SRC_URI = "hg://hg.geexbox.org;proto=http;module=${PN};rev=${SRCREV}"
+
+S = "${WORKDIR}/${PN}"