aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--classes/cross.bbclass1
-rw-r--r--classes/native.bbclass1
-rw-r--r--conf/build/.mtn2git_empty (renamed from packages/nonworking/pptp-linux/.mtn2git_empty)0
-rw-r--r--conf/build/Power Macintosh-darwin.conf1
-rw-r--r--packages/altboot/altboot_1.0.6-rc1.bb82
-rw-r--r--packages/flex/files/flex-lvalue.diff36
-rw-r--r--packages/flex/flex.inc1
-rw-r--r--packages/keymap-locales/files/borzoi/.mtn2git_empty (renamed from packages/nonworking/pptp-linux/pptp-linux/.mtn2git_empty)0
-rw-r--r--packages/keymap-locales/files/borzoi/keymap-extension-2.6-fi.map7
-rw-r--r--packages/matchbox-wm/matchbox-wm/borzoi/.mtn2git_empty0
-rw-r--r--packages/matchbox-wm/matchbox-wm/borzoi/kbdconfig51
-rw-r--r--packages/patcher/patcher_20040913.bb2
-rw-r--r--packages/pptp-linux/.mtn2git_empty0
-rw-r--r--packages/pptp-linux/pptp-linux/.mtn2git_empty0
-rw-r--r--packages/pptp-linux/pptp-linux/makefile.patch (renamed from packages/nonworking/pptp-linux/pptp-linux/makefile.patch)0
-rw-r--r--packages/pptp-linux/pptp-linux/options.pptp (renamed from packages/nonworking/pptp-linux/pptp-linux/options.pptp)0
-rw-r--r--packages/pptp-linux/pptp-linux_1.5.0.bb (renamed from packages/nonworking/pptp-linux/pptp-linux_1.5.0.bb)0
-rw-r--r--packages/quilt/files/non-gnu.patch13
-rw-r--r--packages/quilt/quilt-native_0.42.bb3
-rw-r--r--packages/quilt/quilt_0.42.bb3
-rw-r--r--site/powerpc-darwin7
21 files changed, 204 insertions, 4 deletions
diff --git a/classes/cross.bbclass b/classes/cross.bbclass
index 5d670ccadc..09357acbe8 100644
--- a/classes/cross.bbclass
+++ b/classes/cross.bbclass
@@ -14,6 +14,7 @@ CPPFLAGS = "${BUILD_CPPFLAGS}"
CFLAGS = "${BUILD_CFLAGS}"
CXXFLAGS = "${BUILD_CFLAGS}"
LDFLAGS = "${BUILD_LDFLAGS}"
+LDFLAGS_build-darwin = "-L${STAGING_DIR}/${BUILD_SYS}/lib "
# Overrides for paths
diff --git a/classes/native.bbclass b/classes/native.bbclass
index fea8048fe5..011e48cf62 100644
--- a/classes/native.bbclass
+++ b/classes/native.bbclass
@@ -34,6 +34,7 @@ CPPFLAGS = "${BUILD_CPPFLAGS}"
CFLAGS = "${BUILD_CFLAGS}"
CXXFLAGS = "${BUILD_CFLAGS}"
LDFLAGS = "${BUILD_LDFLAGS}"
+LDFLAGS_build-darwin = "-L${STAGING_DIR}/${BUILD_SYS}/lib "
# Path prefixes
base_prefix = "${exec_prefix}"
diff --git a/packages/nonworking/pptp-linux/.mtn2git_empty b/conf/build/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/nonworking/pptp-linux/.mtn2git_empty
+++ b/conf/build/.mtn2git_empty
diff --git a/conf/build/Power Macintosh-darwin.conf b/conf/build/Power Macintosh-darwin.conf
new file mode 100644
index 0000000000..f56c09243e
--- /dev/null
+++ b/conf/build/Power Macintosh-darwin.conf
@@ -0,0 +1 @@
+BUILD_ARCH="powerpc"
diff --git a/packages/altboot/altboot_1.0.6-rc1.bb b/packages/altboot/altboot_1.0.6-rc1.bb
new file mode 100644
index 0000000000..bb99fe31e5
--- /dev/null
+++ b/packages/altboot/altboot_1.0.6-rc1.bb
@@ -0,0 +1,82 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: altboot_1.0.5-rc2.bb
+# Date: 21-Feb-06
+
+DESCRIPTION = "The altboot bootmanager"
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+HOMEPAGE = "http://www.hentges.net/misc/openzaurus/index.shtml"
+
+######################################################################################
+
+PR = "r0"
+
+######################################################################################
+
+PACKAGE_ARCH = "${MACHINE}"
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '-')}"
+
+SRC_URI = "cvs://anonymous@hentges.net/hentgescvs;method=pserver;tag=${TAG};module=altboot"
+
+S = "${WORKDIR}/altboot/"
+
+######################################################################################
+
+do_install() {
+ install -d ${D}/sbin
+ install -d ${D}/etc/altboot-menu
+ install -d ${D}/etc/altboot-menu/Advanced
+ install -d ${D}/etc/altboot.rc
+ install -d ${D}/usr/share/doc/altboot
+
+ if test -d ${WORKDIR}/altboot/${MACHINE}
+ then
+ install -m 0644 ${WORKDIR}/altboot/${MACHINE}/altboot*.cfg ${D}/etc
+ else
+ install -m 0644 ${WORKDIR}/altboot/altboot*.cfg ${D}/etc
+ fi
+
+ install -m 0644 ${WORKDIR}/altboot/altboot.func ${D}/etc
+ install -m 0755 ${WORKDIR}/altboot/init.altboot ${D}/sbin
+
+ if test -d ${WORKDIR}/altboot/${MACHINE}/altboot-menu/
+ then
+ install -m 0755 ${WORKDIR}/altboot/${MACHINE}/altboot-menu/*-* ${D}/etc/altboot-menu
+ else
+ install -m 0755 ${WORKDIR}/altboot/altboot-menu/*-* ${D}/etc/altboot-menu
+ fi
+
+ if test -d ${WORKDIR}/altboot/${MACHINE}/altboot-menu/Advanced/
+ then
+ install -m 0755 ${WORKDIR}/altboot/${MACHINE}/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
+ else
+ install -m 0755 ${WORKDIR}/altboot/altboot-menu/Advanced/*-* ${D}/etc/altboot-menu/Advanced
+ fi
+
+ install -m 0755 ${WORKDIR}/altboot/altboot.rc/*.sh ${D}/etc/altboot.rc
+ install -m 0644 ${WORKDIR}/altboot/altboot.rc/*.txt ${D}/etc/altboot.rc
+}
+
+######################################################################################
+
+do_configure() {
+ cat ${WORKDIR}/altboot/init.altboot | sed "s/^VERSION=.*/VERSION=\"${PV}\"/" > ${WORKDIR}/altboot/init.altboot_
+ mv ${WORKDIR}/altboot/init.altboot_ ${WORKDIR}/altboot/init.altboot
+}
+
+######################################################################################
+
+pkg_postinst() {
+ update-alternatives --install /sbin/init init /sbin/init.altboot 55
+}
+
+######################################################################################
+
+pkg_postrm() {
+ update-alternatives --remove init /sbin/init.altboot
+}
+
diff --git a/packages/flex/files/flex-lvalue.diff b/packages/flex/files/flex-lvalue.diff
new file mode 100644
index 0000000000..56ae539a6c
--- /dev/null
+++ b/packages/flex/files/flex-lvalue.diff
@@ -0,0 +1,36 @@
+Patch from http://bugs.debian.org/cgi-bin/bugreport.cgi/flex-lvalue.diff?bug=194844;msg=10;att=1
+
+according to posix 0,1,2 are already setup and this avoids
+the issues with
+| filter.c: In function 'filter_apply_chain':
+| filter.c:161: error: invalid lvalue in assignment
+| filter.c:163: error: invalid lvalue in assignment
+| filter.c:184: error: invalid lvalue in assignment
+
+
+diff -ur flex-2.5.31.ORIG/filter.c flex-2.5.31/filter.c
+--- flex-2.5.31.ORIG/filter.c 2003-03-25 16:39:08.000000000 +0000
++++ flex-2.5.31/filter.c 2003-05-27 17:00:26.000000000 +0000
+@@ -157,11 +157,8 @@
+ if (chain->filter_func) {
+ int r;
+
+- /* setup streams again */
+- if ((stdin = fdopen (0, "r")) == NULL)
+- flexfatal (_("fdopen(0) failed"));
+- if ((stdout = fdopen (1, "w")) == NULL)
+- flexfatal (_("fdopen(1) failed"));
++ /* POSIX says we inherit fd[0-2], so we don't need
++ to do anything to them here */
+
+ if ((r = chain->filter_func (chain)) == -1)
+ flexfatal (_("filter_func failed"));
+@@ -181,8 +178,6 @@
+ if (dup2 (pipes[1], 1) == -1)
+ flexfatal (_("dup2(pipes[1],1)"));
+ close (pipes[1]);
+- if ((stdout = fdopen (1, "w")) == NULL)
+- flexfatal (_("fdopen(1) failed"));
+
+ return true;
+ }
diff --git a/packages/flex/flex.inc b/packages/flex/flex.inc
index 6e605ac9be..d6affad226 100644
--- a/packages/flex/flex.inc
+++ b/packages/flex/flex.inc
@@ -3,6 +3,7 @@ SECTION = "devel"
LICENSE = "BSD"
SRC_URI = "${SOURCEFORGE_MIRROR}/lex/flex-2.5.31.tar.bz2 \
+ file://flex-lvalue.diff;patch=1 \
file://fix-gen.patch;patch=1"
S = "${WORKDIR}/flex-${PV}"
diff --git a/packages/nonworking/pptp-linux/pptp-linux/.mtn2git_empty b/packages/keymap-locales/files/borzoi/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/nonworking/pptp-linux/pptp-linux/.mtn2git_empty
+++ b/packages/keymap-locales/files/borzoi/.mtn2git_empty
diff --git a/packages/keymap-locales/files/borzoi/keymap-extension-2.6-fi.map b/packages/keymap-locales/files/borzoi/keymap-extension-2.6-fi.map
new file mode 100644
index 0000000000..4640bd56d4
--- /dev/null
+++ b/packages/keymap-locales/files/borzoi/keymap-extension-2.6-fi.map
@@ -0,0 +1,7 @@
+# Finnish keymapping
+charset "iso-8859-1"
+altgr keycode 24 = +odiaeresis
+altgr keycode 30 = +adiaeresis
+shift altgr keycode 24 = +Odiaeresis
+shift altgr keycode 30 = +Adiaeresis
+
diff --git a/packages/matchbox-wm/matchbox-wm/borzoi/.mtn2git_empty b/packages/matchbox-wm/matchbox-wm/borzoi/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-wm/matchbox-wm/borzoi/.mtn2git_empty
diff --git a/packages/matchbox-wm/matchbox-wm/borzoi/kbdconfig b/packages/matchbox-wm/matchbox-wm/borzoi/kbdconfig
new file mode 100644
index 0000000000..7de0071c08
--- /dev/null
+++ b/packages/matchbox-wm/matchbox-wm/borzoi/kbdconfig
@@ -0,0 +1,51 @@
+#
+# This is an example keyboard config file for matchbox
+#
+# You can edit this file or change per user by copying to
+# ~/.matchbox/kbdconfig
+#
+# Se the matchbox manual for more info ( http://projects.o-hand.com/matchbox )
+
+### Window operation short cuts
+
+<Alt>n=next
+<Alt>p=prev
+<Alt>c=close
+<Alt>d=desktop
+<Alt>m=!matchbox-remote -mbmenu
+
+### App launching.
+
+<ctrl><alt>x=!xterm
+<ctrl><alt>r=!rxvt
+
+### App launching with startup notify
+
+<ctrl><alt>e=!!gpe-calender
+
+### windows style key shortcuts
+
+<alt>Tab=next
+<alt><shift>Tab=prev
+
+<alt>space=taskmenu
+<alt>escape=!matchbox-remote -mbmenu
+<alt>f4=close
+
+# On SL-Cxxxx, F11 is the "menu" key. In order to be able to assign a function
+# to this key via keylaunch, this must be commented out.
+# NOTE: Uncommenting this usually means that matchbox crashes on startup!
+#
+# f11=fullscreen
+
+### super should be a 'window' key, uncomment '#' if you have one.
+
+#<super>d=desktop
+#<super>r=!xterm
+#<super>e=!!nautilus
+
+### Special keys, likely probably only available on extended keyboards.
+
+#App=!matchbox-remote -mbmenu
+#Menu=!matchbox-remote -mbmenu
+
diff --git a/packages/patcher/patcher_20040913.bb b/packages/patcher/patcher_20040913.bb
index 9559f5cf72..af4d91217c 100644
--- a/packages/patcher/patcher_20040913.bb
+++ b/packages/patcher/patcher_20040913.bb
@@ -14,5 +14,3 @@ do_install() {
install -d ${D}${bindir}
install -m 0755 patcher.py ${D}${bindir}/patcher
}
-
-DEPENDS_prepend_delete = "patcher "
diff --git a/packages/pptp-linux/.mtn2git_empty b/packages/pptp-linux/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/pptp-linux/.mtn2git_empty
diff --git a/packages/pptp-linux/pptp-linux/.mtn2git_empty b/packages/pptp-linux/pptp-linux/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/pptp-linux/pptp-linux/.mtn2git_empty
diff --git a/packages/nonworking/pptp-linux/pptp-linux/makefile.patch b/packages/pptp-linux/pptp-linux/makefile.patch
index ea2b5711a2..ea2b5711a2 100644
--- a/packages/nonworking/pptp-linux/pptp-linux/makefile.patch
+++ b/packages/pptp-linux/pptp-linux/makefile.patch
diff --git a/packages/nonworking/pptp-linux/pptp-linux/options.pptp b/packages/pptp-linux/pptp-linux/options.pptp
index f446e22a6a..f446e22a6a 100644
--- a/packages/nonworking/pptp-linux/pptp-linux/options.pptp
+++ b/packages/pptp-linux/pptp-linux/options.pptp
diff --git a/packages/nonworking/pptp-linux/pptp-linux_1.5.0.bb b/packages/pptp-linux/pptp-linux_1.5.0.bb
index d98478d780..d98478d780 100644
--- a/packages/nonworking/pptp-linux/pptp-linux_1.5.0.bb
+++ b/packages/pptp-linux/pptp-linux_1.5.0.bb
diff --git a/packages/quilt/files/non-gnu.patch b/packages/quilt/files/non-gnu.patch
new file mode 100644
index 0000000000..8b07bc2923
--- /dev/null
+++ b/packages/quilt/files/non-gnu.patch
@@ -0,0 +1,13 @@
+Index: quilt/Makefile.in
+===================================================================
+--- quilt.orig/Makefile.in
++++ quilt/Makefile.in
+@@ -216,7 +216,7 @@
+ -e 's:@LOCALEDIR''@:$(localedir):g' \
+ -e 's:@DOCSUBDIR''@:$(docdir)/$(PACKAGE)-$(VERSION):g' \
+ $< > $@
+- @chmod --reference=$< $@
++ @chmod `stat -f "%p" $<` $@
+
+ Makefile : Makefile.in
+ @echo "Please run ./configure by hand"
diff --git a/packages/quilt/quilt-native_0.42.bb b/packages/quilt/quilt-native_0.42.bb
index 19b4a3b865..959bcfcb57 100644
--- a/packages/quilt/quilt-native_0.42.bb
+++ b/packages/quilt/quilt-native_0.42.bb
@@ -7,7 +7,8 @@ RDEPENDS_${PN} = "diffstat-native patch-native bzip2-native"
SRC_URI = "cvs://anonymous@cvs.savannah.nongnu.org/cvsroot/quilt;method=pserver;module=quilt;tag=VER_${@(bb.data.getVar('PV', d, 1) or '').replace('.', '_')} \
file://install.patch;patch=1 \
file://nostrip.patch;patch=1 \
- file://autoreconf.patch;patch=1"
+ file://autoreconf.patch;patch=1 \
+ file://non-gnu.patch;patch=1 "
S = "${WORKDIR}/quilt"
inherit autotools native
diff --git a/packages/quilt/quilt_0.42.bb b/packages/quilt/quilt_0.42.bb
index 44a0d9529b..d4be31a02a 100644
--- a/packages/quilt/quilt_0.42.bb
+++ b/packages/quilt/quilt_0.42.bb
@@ -2,7 +2,8 @@ include quilt.inc
SRC_URI = "cvs://anonymous@cvs.savannah.nongnu.org/cvsroot/quilt;method=pserver;module=quilt;tag=VER_${@(bb.data.getVar('PV', d, 1) or '').replace('.', '_')} \
file://install.patch;patch=1 \
- file://nostrip.patch;patch=1"
+ file://nostrip.patch;patch=1 \
+ file://non-gnu.patch;patch=1 "
S = "${WORKDIR}/quilt"
inherit autotools gettext
diff --git a/site/powerpc-darwin b/site/powerpc-darwin
new file mode 100644
index 0000000000..085f50b034
--- /dev/null
+++ b/site/powerpc-darwin
@@ -0,0 +1,7 @@
+# pkgconfig-native for OS X buid
+ac_cv_sizeof_char=${ac_cv_sizeof_char=1}
+ac_cv_sizeof_int=${ac_cv_sizeof_int=4}
+ac_cv_sizeof_long=${ac_cv_sizeof_long=4}
+ac_cv_sizeof_long_long=${ac_cv_sizeof_long_long=8}
+ac_cv_sizeof_short=${ac_cv_sizeof_short=2}
+ac_cv_sizeof_void_p=${ac_cv_sizeof_void_p=4}