aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/openmoko-3rdparty/spojegui_svn.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes/openmoko-3rdparty/spojegui_svn.bb b/recipes/openmoko-3rdparty/spojegui_svn.bb
index a0700e0112..8e94d7b042 100644
--- a/recipes/openmoko-3rdparty/spojegui_svn.bb
+++ b/recipes/openmoko-3rdparty/spojegui_svn.bb
@@ -8,7 +8,7 @@ RDEPENDS_${PN} = "python-core python-elementary python-sqlite3 python-netclient"
SRCREV = "64"
PV = "0.4.2+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
S = "${WORKDIR}/build"
@@ -16,6 +16,12 @@ PACKAGE_ARCH = "all"
SRC_URI = "svn://xeres.cz/spoje;module=build"
+# override base_do_compile with own as included Makefile calls ipkg-build and it's not usefull to us at all
+do_compile() {
+ # fix QA issue
+ sed -i '/^Encoding/d;/^Version/d;s/Categories=Application;/Categories=Utility;/g' ${S}/data/spoje.desktop
+}
+
do_install() {
install -d "${D}/${bindir}"
install -m 0755 "${S}/src/spoje.py" "${D}/${bindir}"