aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch-fe.de>2012-09-28 12:13:19 +0200
committerSteffen Sledz <sledz@dresearch-fe.de>2012-09-28 12:13:19 +0200
commit3cc90251ccf802274a95f736784f532e21166afb (patch)
tree05a2471a8859992f08faa9ad39996ce1bc3d1c22 /recipes
parenta35ceaacb2019750dc9f4b4fd5ea927cf2ad47fb (diff)
downloadopenembedded-3cc90251ccf802274a95f736784f532e21166afb.tar.gz
jamvm: reorganize metadata to simplify backport from meta-java
Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/jamvm/files/jamvm_1.5.0-initial.patch91
-rw-r--r--recipes/jamvm/jamvm-initial/jamvm_1.4.5-initial.patch (renamed from recipes/jamvm/files/jamvm_1.4.5-initial.patch)0
-rw-r--r--recipes/jamvm/jamvm/debian-jni.patch (renamed from recipes/jamvm/files/debian-jni.patch)0
-rw-r--r--recipes/jamvm/jamvm/jamvm-1.3.1-size-defaults.patch (renamed from recipes/jamvm/files/jamvm-1.3.1-size-defaults.patch)0
-rw-r--r--recipes/jamvm/jamvm/jamvm-1.5.3-jni_h-noinst.patch (renamed from recipes/jamvm/files/jamvm-1.5.3-jni_h-noinst.patch)0
5 files changed, 0 insertions, 91 deletions
diff --git a/recipes/jamvm/files/jamvm_1.5.0-initial.patch b/recipes/jamvm/files/jamvm_1.5.0-initial.patch
deleted file mode 100644
index 1f63dba3e3..0000000000
--- a/recipes/jamvm/files/jamvm_1.5.0-initial.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-Index: jamvm-1.5.0/configure.ac
-===================================================================
---- jamvm-1.5.0.orig/configure.ac 2007-12-20 00:01:08.000000000 +0100
-+++ jamvm-1.5.0/configure.ac 2007-12-20 00:03:40.000000000 +0100
-@@ -22,7 +22,7 @@
- dnl Process this file with autoconf to produce a configure script.
-
- AC_INIT(src/jam.c)
--AM_INIT_AUTOMAKE(jamvm, 1.5.0)
-+AM_INIT_AUTOMAKE(jamvm-initial, 1.5.0)
- AC_CONFIG_HEADERS([src/config.h])
- AC_PREFIX_DEFAULT(/usr/local/jamvm)
-
-Index: jamvm-1.5.0/java-initial
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ jamvm-1.5.0/java-initial 2007-12-20 00:03:27.000000000 +0100
-@@ -0,0 +1,14 @@
-+#!/bin/sh
-+#
-+# Wrapper which (almost) silently restarts the VM in case of segfaults.
-+
-+redo_from_start=1;
-+while [ $redo_from_start -eq 1 ]; do
-+ echo "Running JamVM-initial: ${@}"
-+ redo_from_start=0;
-+ jamvm-initial ${1+"$@"}
-+ if [ $? -eq 139 ]; then
-+ echo "JamVM-initial crashed - silently trying again"
-+ redo_from_start=1;
-+ fi
-+done
-Index: jamvm-1.5.0/lib/Makefile.am
-===================================================================
---- jamvm-1.5.0.orig/lib/Makefile.am 2007-12-20 00:05:24.000000000 +0100
-+++ jamvm-1.5.0/lib/Makefile.am 2007-12-20 00:05:28.000000000 +0100
-@@ -19,7 +19,7 @@
- ## Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
- ##
-
--CP_LIB_DIR = ${with_classpath_install_dir}/share/classpath
-+CP_LIB_DIR = ${with_classpath_install_dir}/share/classpath-initial
- GLIBJ_ZIP = ${CP_LIB_DIR}/glibj.zip
-
- SUBDIRS = jamvm java gnu sun
-Index: jamvm-1.5.0/src/class.h
-===================================================================
---- jamvm-1.5.0.orig/src/class.h 2007-12-20 00:06:34.000000000 +0100
-+++ jamvm-1.5.0/src/class.h 2007-12-20 00:16:41.000000000 +0100
-@@ -39,11 +39,11 @@
- separate class files in a directory structure */
-
- #ifdef USE_ZIP
--#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes.zip"
--#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath/glibj.zip"
-+#define JAMVM_CLASSES CLASSPATH_INSTALL_DIR"/share/jamvm-initial/classes.zip"
-+#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath-initial/glibj.zip"
- #else
--#define JAMVM_CLASSES INSTALL_DIR"/share/jamvm/classes"
--#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath"
-+#define JAMVM_CLASSES CLASSPATH_INSTALL_DIR"/share/jamvm-initial/classes"
-+#define CLASSPATH_CLASSES CLASSPATH_INSTALL_DIR"/share/classpath-initial"
- #endif
-
- #define DFLT_BCP JAMVM_CLASSES":"CLASSPATH_CLASSES
-Index: jamvm-1.5.0/src/dll.c
-===================================================================
---- jamvm-1.5.0.orig/src/dll.c 2007-12-20 00:01:24.000000000 +0100
-+++ jamvm-1.5.0/src/dll.c 2007-12-20 00:03:27.000000000 +0100
-@@ -294,7 +294,7 @@
- }
-
- char *getBootDllPath() {
-- return CLASSPATH_INSTALL_DIR"/lib/classpath";
-+ return CLASSPATH_INSTALL_DIR"/lib/classpath-initial";
- }
-
- char *getDllName(char *name) {
-Index: jamvm-1.5.0/src/Makefile.am
-===================================================================
---- jamvm-1.5.0.orig/src/Makefile.am 2007-12-20 00:21:37.000000000 +0100
-+++ jamvm-1.5.0/src/Makefile.am 2007-12-20 00:21:46.000000000 +0100
-@@ -23,7 +23,7 @@
- DIST_SUBDIRS = os arch interp
-
- bin_PROGRAMS = jamvm
--include_HEADERS = jni.h
-+noinst_HEADERS = jni.h
-
- lib_LTLIBRARIES = libjvm.la
- noinst_LTLIBRARIES = libcore.la
diff --git a/recipes/jamvm/files/jamvm_1.4.5-initial.patch b/recipes/jamvm/jamvm-initial/jamvm_1.4.5-initial.patch
index 175052dbf3..175052dbf3 100644
--- a/recipes/jamvm/files/jamvm_1.4.5-initial.patch
+++ b/recipes/jamvm/jamvm-initial/jamvm_1.4.5-initial.patch
diff --git a/recipes/jamvm/files/debian-jni.patch b/recipes/jamvm/jamvm/debian-jni.patch
index 040163da69..040163da69 100644
--- a/recipes/jamvm/files/debian-jni.patch
+++ b/recipes/jamvm/jamvm/debian-jni.patch
diff --git a/recipes/jamvm/files/jamvm-1.3.1-size-defaults.patch b/recipes/jamvm/jamvm/jamvm-1.3.1-size-defaults.patch
index a41beee982..a41beee982 100644
--- a/recipes/jamvm/files/jamvm-1.3.1-size-defaults.patch
+++ b/recipes/jamvm/jamvm/jamvm-1.3.1-size-defaults.patch
diff --git a/recipes/jamvm/files/jamvm-1.5.3-jni_h-noinst.patch b/recipes/jamvm/jamvm/jamvm-1.5.3-jni_h-noinst.patch
index f0884fd838..f0884fd838 100644
--- a/recipes/jamvm/files/jamvm-1.5.3-jni_h-noinst.patch
+++ b/recipes/jamvm/jamvm/jamvm-1.5.3-jni_h-noinst.patch