summaryrefslogtreecommitdiffstats
path: root/recipes/webkit
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-07 19:36:57 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-07 19:36:57 +0100
commit286db7631ff17f5a086c337914df97a3db65900e (patch)
treea315deedfb0627db24604cb5010ef4097e76d217 /recipes/webkit
parent252dc53aa97d3f284078b7d89a9f6b7792ce7466 (diff)
downloadopenembedded-286db7631ff17f5a086c337914df97a3db65900e.tar.gz
arora: factor common stuff into .inc and add qt4/embedded version
Diffstat (limited to 'recipes/webkit')
-rw-r--r--recipes/webkit/arora-e_0.10.1.bb3
-rw-r--r--recipes/webkit/arora.inc45
-rw-r--r--recipes/webkit/arora_0.10.1.bb44
3 files changed, 49 insertions, 43 deletions
diff --git a/recipes/webkit/arora-e_0.10.1.bb b/recipes/webkit/arora-e_0.10.1.bb
new file mode 100644
index 0000000000..a526fda715
--- /dev/null
+++ b/recipes/webkit/arora-e_0.10.1.bb
@@ -0,0 +1,3 @@
+inherit qt4e
+
+require arora.inc
diff --git a/recipes/webkit/arora.inc b/recipes/webkit/arora.inc
new file mode 100644
index 0000000000..bbd8bfb33e
--- /dev/null
+++ b/recipes/webkit/arora.inc
@@ -0,0 +1,45 @@
+DESCRIPTION = "Arora is a lightweight cross-platform web browser"
+LICENE = "GPLv2"
+HOMEPAGE = "http://code.google.com/p/arora/"
+
+PR = "r1"
+
+SRC_URI = "http://arora.googlecode.com/files/arora-${PV}.tar.gz"
+
+S = "${WORKDIR}/arora-${PV}"
+
+do_configure_prepend() {
+ sed -i -e s:lrelease-qt4:${OE_QMAKE_LRELEASE}:g ${S}/src/locale/locale.pri
+}
+
+# Huge hack ahead:
+# Something is putting '.libs' in the Makefiles, which we do now want. The problem is that qmake generates makefiles during 'make all' *sigh*
+do_compile_prepend() {
+ ( oe_runmake src/Makefile tools/Makefile
+ cd ${S}/tools ; oe_runmake cacheinfo/Makefile htmlToXBel/Makefile placesimport/Makefile
+ )
+
+ for i in $(find ${S} -name 'Makefile') ; do
+ sed -i -e 's:/.libs::g' $i
+ make || true
+ done
+
+}
+
+do_install() {
+ sed -i -e s:/usr/local:${D}${prefix}:g install.pri
+ sed -i -e s:$(INSTALL_ROOT)/OE/angstrom-dev/work/armv7a-angstrom-linux-gnueabi/arora-0.10.1-r0/image/:$(INSTALL_ROOT)/:g src/Makefile
+
+ for i in $(find ${S} -name 'Makefile') ; do
+ sed -i -e s:/usr/local:${prefix}:g $i
+ done
+
+ oe_runmake -e INSTALL_ROOT=${D} install
+ cp -r ${D}/${D}/* ${D}/ || true
+ cp -r ${D}/usr/local/* ${D}${prefix} || true
+ rm -rf ${D}/usr/local ${D}/${D}
+}
+
+FILES_${PN} += "${datadir}/arora ${datadir}/gnome-control-center ${datadir}/icons"
+
+
diff --git a/recipes/webkit/arora_0.10.1.bb b/recipes/webkit/arora_0.10.1.bb
index 11da72e5ff..ea90c4538a 100644
--- a/recipes/webkit/arora_0.10.1.bb
+++ b/recipes/webkit/arora_0.10.1.bb
@@ -1,45 +1,3 @@
-DESCRIPTION = "Arora is a lightweight cross-platform web browser"
-LICENE = "GPLv2"
-HOMEPAGE = "http://code.google.com/p/arora/"
-
inherit qt4x11
-PR = "r1"
-
-SRC_URI = "http://arora.googlecode.com/files/arora-${PV}.tar.gz"
-
-do_configure_prepend() {
- sed -i -e s:lrelease-qt4:${OE_QMAKE_LRELEASE}:g ${S}/src/locale/locale.pri
-}
-
-# Huge hack ahead:
-# Something is putting '.libs' in the Makefiles, which we do now want. The problem is that qmake generates makefiles during 'make all' *sigh*
-do_compile_prepend() {
- ( oe_runmake src/Makefile tools/Makefile
- cd ${S}/tools ; oe_runmake cacheinfo/Makefile htmlToXBel/Makefile placesimport/Makefile
- )
-
- for i in $(find ${S} -name 'Makefile') ; do
- sed -i -e 's:/.libs::g' $i
- make || true
- done
-
-}
-
-do_install() {
- sed -i -e s:/usr/local:${D}${prefix}:g install.pri
- sed -i -e s:$(INSTALL_ROOT)/OE/angstrom-dev/work/armv7a-angstrom-linux-gnueabi/arora-0.10.1-r0/image/:$(INSTALL_ROOT)/:g src/Makefile
-
- for i in $(find ${S} -name 'Makefile') ; do
- sed -i -e s:/usr/local:${prefix}:g $i
- done
-
- oe_runmake -e INSTALL_ROOT=${D} install
- cp -r ${D}/${D}/* ${D}/ || true
- cp -r ${D}/usr/local/* ${D}${prefix} || true
- rm -rf ${D}/usr/local ${D}/${D}
-}
-
-FILES_${PN} += "${datadir}/gnome-control-center ${datadir}/icons"
-
-
+require arora.inc