aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-openmoko-2.6.32_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-12-22 10:24:55 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-12-22 10:44:09 +0100
commit96ef8994798341d274bcf9acf62efb69c14632ca (patch)
tree8e46059ba35cbd62fe7794fd2b31fe1c769c363c /recipes/linux/linux-openmoko-2.6.32_git.bb
parent4c28b1df18d0c31e841b98274db0c22e6f032c43 (diff)
downloadopenembedded-96ef8994798341d274bcf9acf62efb69c14632ca.tar.gz
linux-openmoko-2.6.32: add new version
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/linux/linux-openmoko-2.6.32_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-2.6.32_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.32_git.bb b/recipes/linux/linux-openmoko-2.6.32_git.bb
new file mode 100644
index 0000000000..8de43b97b1
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.32_git.bb
@@ -0,0 +1,24 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
+
+KERNEL_RELEASE = "2.6.32"
+KERNEL_VERSION = "${KERNEL_RELEASE}"
+
+OEV = "oe1"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-gta02-2.6.32 \
+ file://defconfig \
+# build fix
+ file://0001-wm8753-fix-build-with-gcc-4.4.2-which-works-ok-with-.patch;patch=1 \
+"
+
+S = "${WORKDIR}/git"
+
+do_configure_prepend() {
+ install -m 644 ${WORKDIR}/defconfig ${WORKDIR}/defconfig-oe
+}